Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-11-2014, 08:04 AM   #1
Junior Member
 
Join Date: Jun 2014
Posts: 4
Water Problem Beaver Patriot Thunder

I am having an issue with filling my fresh water tank in the coach and water pressure when hooked up to city water' '
Can and one tell me if there is a filter somewhere I don't know about or what may cause this restriction....frustrated!!!
__________________

__________________
Patriot Thunder is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-11-2014, 09:40 AM   #2
Senior Member
 
Country Coach Owners Club
Retired Fire Service RVer's
Join Date: Feb 2013
Location: Ocala, Florida
Posts: 6,295
Welcome and glad to meet you!

Sorry, can't help with your particular problem.
__________________

__________________
FMCA #F431170, GS #822128658, Escapees SKP #112655
2012 Airstream Mercedes Interstate Class B
[SIGPIC][/SIGPIC]
Medico is offline   Reply With Quote
Old 06-11-2014, 09:50 AM   #3
Community Administrator
 
JohnRR's Avatar


 
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Sep 2010
Location: Marquette, Michigan "Da UP"
Posts: 16,940

Your Intro is being moved to try and get you more answers
__________________
John & Cathy R.
06 Pace Arrow 38L W24
08 14 Lincoln MKX AWD
See My RV Upgrades
JohnRR is offline   Reply With Quote
Old 06-11-2014, 10:51 AM   #4
Senior Member
 
Country Coach Owners Club
Join Date: Jan 2006
Location: Redding
Posts: 3,412
My rig fills faster with the water pump turned on. Have you tried that approach?
__________________
Dean
1995 CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is offline   Reply With Quote
Old 06-11-2014, 10:54 AM   #5
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 26,317
Welcome to IRV2! it's great to have you join the gang!

I'm not familiar with the Beaver so can't be of any help on your problem. I'm sure someone will jump in with some suggestions.

Good luck, happy trails, and God bless!
__________________
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is online now   Reply With Quote
Old 06-11-2014, 11:36 AM   #6
Senior Member
 
Davdeb1's Avatar


 
Monaco Owners Club
Freightliner Owners Club
iRV2 No Limits Club
Join Date: Jan 2011
Location: Avon Lake, Oh
Posts: 2,884
The very first thing to look at is the pressure regulator. Unless you have a very good one, they clog up pretty easily. Even the good ones with pressure guages have to be rebuilt every so often. This affects the rate you fill you tank at and your water pressure. If you can turn off the outside spigot, then turn on the pump inside, you will probably see better pressure with the pump. That's a good sign pointing toward replacing your pressure regulator.
__________________
2000 HOLIDAY RAMBLER ENDEAVOR
40 FT--330HP CAT
2 SLIDES-TOAD 2012 focus
Fulltime-Home is where we park it.
Davdeb1 is offline   Reply With Quote
Old 07-12-2014, 12:52 PM   #7
Senior Member
 
gemert's Avatar
 
Monaco Owners Club
Join Date: Mar 2014
Posts: 847
Quote:
Originally Posted by Patriot Thunder View Post
I am having an issue with filling my fresh water tank in the coach and water pressure when hooked up to city water' '
Can and one tell me if there is a filter somewhere I don't know about or what may cause this restriction....frustrated!!!
Did you ever figure this out? I'm having a similar issue. Water tank fills fine but pressure is low on city water.
My water pump has also stopped pumping water which may be my fault because it worked before I was messing with things trying to find the low pressure problem.
__________________
Jerry, "EWC (SW)" USN Retired
2003 Beaver Patriot Thunder 505 HP C-12 1550 TQ
Allison 4000MH Ram 4X4 towed
gemert is offline   Reply With Quote
Old 07-12-2014, 05:36 PM   #8
Senior Member
 
distaff's Avatar
 
Join Date: Dec 2009
Posts: 1,191
Helps if you provide some details such as the year of your coach. I have an '06 and I had low pressure on city water, but acceptable pressure on the pump. In my case it was a seized up Watts pressure regulator. Mine was near the water pump - behind a sliding panel on the rear side of the rear cargo hold adjacent to the wet bay on the road side of the coach. I took mine out and have since rebuilt it. It now gets installed on the hose between the hose and the source of city water.

I have never been able to fill from the hose, I have always had to use the city fill port at the top of my wet bay.

You may have two different problems.
__________________
Paul
2006 Patriot Thunder C13 Allison 4000
2010 Ford Flex Ecoboost AWD
distaff is offline   Reply With Quote
Old 07-12-2014, 05:37 PM   #9
Senior Member
 
distaff's Avatar
 
Join Date: Dec 2009
Posts: 1,191
I will also mention that you will get quicker answers if you post questions that are specific to the Beaver on the Monaco forum on this site.
__________________
Paul
2006 Patriot Thunder C13 Allison 4000
2010 Ford Flex Ecoboost AWD
distaff is offline   Reply With Quote
Old 07-13-2014, 12:06 PM   #10
Senior Member
 
gemert's Avatar
 
Monaco Owners Club
Join Date: Mar 2014
Posts: 847
Quote:
Originally Posted by distaff View Post
I will also mention that you will get quicker answers if you post questions that are specific to the Beaver on the Monaco forum on this site.
Coach info is in my signature, 2003 Beaver patriot thunder.
Water pressure was fine on pump low on shore water. after poking around the pump now doesn't move water. It is making noise but not pumping. Tank is full, tank fill valve is off, all valves lined up correctly. I'm stumped. The question has also been asked in BAC forum. Just thought your problem may give me another idea. Thanks for your response.
__________________

__________________
Jerry, "EWC (SW)" USN Retired
2003 Beaver Patriot Thunder 505 HP C-12 1550 TQ
Allison 4000MH Ram 4X4 towed
gemert is offline   Reply With Quote
Reply

Tags
beaver, water



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fresh water pump problem. Dan50 5th Wheel Discussion 4 06-03-2014 08:56 PM
97 Beaver problem RanchoT Vintage RV's 1 03-22-2014 01:26 AM
No hot water in Kodiak GretkasonRD Travel Trailer Discussion 5 02-13-2014 10:30 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:48 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.