Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-07-2014, 01:25 PM   #1
Member
 
Join Date: Jan 2013
Posts: 34
Water Pump Cycling

I bought a 98 Fleetwood Southwind Storm used and 2013 was my first year of RVing. Everything went quite well, did have problems with the generator not starting (of course it ran before we left home). Turned out being a poor ground within the genee. The one thing that bothered me was the water pump cycling on and off when the tap was partially open. Don't these systems have cushion tanks? Maybe the previous owner removed it?
Mike
__________________

__________________
Serenity00 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-07-2014, 01:31 PM   #2
Senior Member
 
Join Date: Jan 2014
Location: Centennial, CO
Posts: 405
None that I know of come with expansion tanks...they all cycle off and on when the faucet (or a leak!) is open a bit. You can install an expansion tank and help some, I don't know how much though...

Tim
__________________

__________________
Timay is offline   Reply With Quote
Old 01-07-2014, 01:44 PM   #3
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 4,383
If you buy a tank, get the one with the rubber bladder and air fill. It stops cycling much better.
__________________
1998 Pace Arrow 35 ft. F53 Ford V10 2012 Honda Civic toad
32 years mechanic at Delta Air Lines 15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is offline   Reply With Quote
Old 01-07-2014, 01:51 PM   #4
Senior Member
 
Damon Owners Club
Join Date: Jul 2010
Location: Annapolis,MD
Posts: 1,194
There are also higher end pumps that have variable speeds, so
they cycle very quietly, virtually silent depending on location.
IMHO, would be the simplest fix.
__________________
macandphyl is online now   Reply With Quote
Old 01-07-2014, 02:33 PM   #5
Member
 
Join Date: Jan 2013
Location: N.H.
Posts: 36
Camping world has a Shurflo Accumulator Tank on sale $38.00 have a similar set up on my pump, cuts down cycling considerably easy install.

good luck
Rick
__________________
rick h is offline   Reply With Quote
Reply

Tags
water, water pump



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bounder: Water pump switches do not turn pump on roilacres Fleetwood Products Owner's Forum 8 01-19-2014 04:30 PM
Water pump runs for a couple of seconds then shuts off wpatters1229 RV Systems & Appliances 13 12-06-2013 01:45 PM
New water pump won't work canuckdave Monaco Owner's Forum 7 11-29-2013 06:30 PM
Water pump alluran Monaco Owner's Forum 4 11-08-2013 06:50 PM
Water From Pump Not Working '05 Allegro DP40 kdzzack Tiffin Motorhomes Owners Forum 6 07-10-2013 04:02 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.