Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-27-2012, 06:43 AM   #1
Senior Member
 
mc4fun's Avatar


 
Newmar Owners Club
Freightliner Owners Club
Join Date: Apr 2012
Location: Memphis, TN ,,,, USA
Posts: 732
WAter Pump Help

OK, so in getting ready for the trip today I try to get some water out of the faucet in the kitchen, and nothing. So I go and check the outside shower and it is turend off.

I have found 2 switches for the water pump, each is a switch tat only stays in one position.
The one in the Water bay is in the on position, I can push it ot off, but it flis right back up. The one on the control board where the tank levels are is always in the off position. I push it ot the on position and I get a quick blink of the Red light right under it and there nothing.......

I am running on the Genset, 1/4 fresh water, all the other tanks are empty.
__________________

__________________
Stefan, Nicole, and Ian
The Pups - Kaiser, Indar, Itsa, and Marty
2015 Newmar DS 4369
BlueOx Aladdin Toads: Tahoe or 2500HD, BrakeBuddy Classic
mc4fun is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-27-2012, 06:52 AM   #2
Senior Member
 
H. Miller's Avatar
 
Monaco Owners Club
Texas Boomers Club
Join Date: Jan 2009
Posts: 2,523
Sounds like a pump to me...
__________________

__________________
Hal & Ginny Miller '04 Beaver Santiam PRT40
'04 Saturn Vue - US Gear Brake - Blue Ox tow
4"girls" (3 Irish Setters - 1 Retriever) - RIP Annie
H. Miller is offline   Reply With Quote
Old 04-27-2012, 06:53 AM   #3
Senior Member
 
clyon51's Avatar
 
Monaco Owners Club
Join Date: Mar 2012
Location: Arizona West RV Park, Yuma, Az
Posts: 4,113
Is this after a winterization? Unless you varify the pump is not running, you are not going to get water flowing until the HW tank is full.
__________________
John & Clare Lyon
2007 43.5' Monaco Dynasty Palace III (All Electric)
Towd: 2011 Chevy Equinox
clyon51 is offline   Reply With Quote
Old 04-27-2012, 08:43 AM   #4
paz
Senior Member
 
paz's Avatar
 
Join Date: May 2005
Location: Full-timers - Home is where we park it.
Posts: 4,716
If the pump is not running, it may be a 12V fuse somewhere that is blown or that the pump itself is bad or the relay for the pump is bad. Where there are multiple switches for the pump, they are usually only momentary contact switches, not off/on switches that flip from one position to another. Pressing the switch activates a latching relay. Pressing the switch a second time (or pressing another one of the switches) makes contact again and deactivates the relay. On our motorhome, the relay is behind a panel near the water tank. Sometimes a relay will stick, and you can rap on it with a screwdriver handle to get it working again.

If the pump is running and you have no water coming out, I suspect someone left a winterizing valve in the wrong position.
__________________
2015 DRV Tradition 375KPS
2015 Chevy Duramax 3500HD LTZ Dually
Full-timers...Home is where we park it.
Check out our blog: Living Our Dream
paz is offline   Reply With Quote
Old 04-27-2012, 09:23 AM   #5
Senior Member
 
mc4fun's Avatar


 
Newmar Owners Club
Freightliner Owners Club
Join Date: Apr 2012
Location: Memphis, TN ,,,, USA
Posts: 732
Well I brought it back to the dealer and they are telling me it may be the switch in the main panel so I will see what they come up with..... I know we are looking at leaving in about 2.5 hours so I hope they can rig it up for this weekend and order the switch
__________________
Stefan, Nicole, and Ian
The Pups - Kaiser, Indar, Itsa, and Marty
2015 Newmar DS 4369
BlueOx Aladdin Toads: Tahoe or 2500HD, BrakeBuddy Classic
mc4fun is offline   Reply With Quote
Old 04-27-2012, 09:52 AM   #6
Senior Member
 
mc4fun's Avatar


 
Newmar Owners Club
Freightliner Owners Club
Join Date: Apr 2012
Location: Memphis, TN ,,,, USA
Posts: 732
Dealer found switch and pump bad. Is replacing both for me at no cost......And it will be done in about an hour.......still in time to make trip ....great customers service also
__________________
Stefan, Nicole, and Ian
The Pups - Kaiser, Indar, Itsa, and Marty
2015 Newmar DS 4369
BlueOx Aladdin Toads: Tahoe or 2500HD, BrakeBuddy Classic
mc4fun is offline   Reply With Quote
Old 04-27-2012, 11:32 AM   #7
Senior Member
 
mc4fun's Avatar


 
Newmar Owners Club
Freightliner Owners Club
Join Date: Apr 2012
Location: Memphis, TN ,,,, USA
Posts: 732
After the pump install they figured out that a control mod. was also bad. This part has to be ordered, the tec. Is trying to install a workaround right now until the part comes in
__________________

__________________
Stefan, Nicole, and Ian
The Pups - Kaiser, Indar, Itsa, and Marty
2015 Newmar DS 4369
BlueOx Aladdin Toads: Tahoe or 2500HD, BrakeBuddy Classic
mc4fun is offline   Reply With Quote
Reply

Tags
water



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.