Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-14-2016, 04:14 PM   #15
Senior Member
 
ChasA's Avatar
 
Join Date: Mar 2007
Location: Apex, NC
Posts: 1,857
Bob, it sounds like your "tank fill/city" valve is in the tank fill position. Turn it to the city position and see if that doesn't stop the constant running of the pump.
__________________

__________________
2010 Winnebago Journey Express 34Y
2010 Freightliner XCS (mfd 9/'09)
'07 Saturn Vue V6
ChasA is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-17-2016, 04:49 PM   #16
Senior Member
 
DD788Snipe's Avatar


 
Newmar Owners Club
Spartan Chassis
Join Date: Jun 2013
Location: Apple Valley CA
Posts: 850
Quote:
Originally Posted by ChasA View Post
Bob, it sounds like your "tank fill/city" valve is in the tank fill position. Turn it to the city position and see if that doesn't stop the constant running of the pump.
I agree. Turn the valve clockwise and I would bet that everything will work just fine Bob. The pump doesn't pressurize the tank it only pressurizes the plumbing. When the fill valve is open to fill the fresh water tank the pump just circulates the water from the tank back to the tank if it's turned on. That's why it continues to run when it's open.
__________________

__________________

Craig & Carolyn Roberts Apple Valley, CA
2006 Newmar 3910 KSDP 400 ISL Cummins Spartan Mountian Master Chassis
Toad: 2010 Chevy Colorado 4X4
DD788Snipe is offline   Reply With Quote
Old 07-18-2016, 07:41 AM   #17
Member
 
Join Date: Jun 2015
Location: Leland, NC
Posts: 75
Turning the water fill knob did the job. The confusion came from the labeling, when you turn to the right the 'On' label is showing and the reverse is true when turning to the left. I read that as the function being enabled instead of disabled.

Thanks,
Bob
__________________
2008 Newmar Ventana, 2016 Ford Fusion Tow
Donna, three Rescue Yorkies and CoCo the Chihuahua
USMC 1955 -- 1980
BobrUSMC is offline   Reply With Quote
Old 07-18-2016, 07:58 AM   #18
Senior Member
 
bruceisla's Avatar
 
Join Date: Oct 2012
Location: Land O Lakes, FL
Posts: 4,454
Quote:
Originally Posted by BobrUSMC View Post
Turning the water fill knob did the job. The confusion came from the labeling, when you turn to the right the 'On' label is showing and the reverse is true when turning to the left. I read that as the function being enabled instead of disabled.

Thanks,
Bob
Yeah ... I have a plug on a tether taped to the hose (hose is on a reel). I cap the hose when I disconnect so I don't suck air when the selector isn't switched to "tank fill". Keeps critters out of the hose too.
__________________

__________________
2005 Newmar Essex 4502, 2013 Caddy SRX
1997 HR Endeavor 37, CAT, 1996 Geo Tracker
bruceisla is offline   Reply With Quote
Reply

Tags
cat, newmar, water, water pump



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New 1st time RVer with 2003 Newmar Kountry Star! Mike Bartelt Newmar Owner's Forum 24 05-31-2016 04:54 PM
2003 Newmar Kountry Star Fuse Panel? BobrUSMC Class A Motorhome Discussions 4 12-17-2015 12:21 PM
2003 Newmar Kountry Star Class A Broken Front Entry Door Stepwell Motor--Help heyskipper Newmar Owner's Forum 2 03-27-2015 10:49 PM
07 Kountry Star 3910 vs. 08 Kountry Star 3910 rickmc Newmar Owner's Forum 4 07-07-2014 12:11 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:50 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.