Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 07-29-2015, 07:06 PM   #1
Junior Member
mikemac3's Avatar
Join Date: Jul 2015
Posts: 29
Where does this wire go?

Trying to diagnose the cause of my tachometer and engine temp gauges not reading (instead they are flopping all over). Found this wire that looks like it either needs a cap or should be connected to something. If you know, could you direct me to what it connects to or where I can buy its cap.

I'm driving a new to me 2000 Allegro Bus with 350 HP cummins on a frieghtliner chassis. The wire is on the left side of the Allison transmission right near the data plate.

Hoping this mystery will solve all of my problems.

Thanks for the help!

Click image for larger version

Name:	ImageUploadedByTapatalk1438218246.506544.jpg
Views:	54
Size:	330.0 KB
ID:	101540Click image for larger version

Name:	ImageUploadedByTapatalk1438218178.819916.jpg
Views:	55
Size:	320.0 KB
ID:	101538Click image for larger version

Name:	ImageUploadedByTapatalk1438218213.602642.jpg
Views:	52
Size:	317.3 KB
ID:	101539

mikemac3 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-29-2015, 10:43 PM   #2
Senior Member
BFlinn181's Avatar

Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 12,624
If there's no matching wire and plug within reach of that plug, I'm not sure it will solve your issues. The tach and engine temperature signals probably come from your ECU, so a dirty connection there could be the culprit. In addition, a bad ground under the dash could also cause jumping gauges.

I'd start checking all connections at the engine and work forward, unclipping, spraying clean the contacts, and reconnecting as you go.


Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote
Old 07-29-2015, 10:52 PM   #3
Senior Member
Skip426's Avatar

Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 11,949
Mike ; have you checked back on your other post ? Wiring is for a mid trans sensor that Allison no longer uses. Should be cleaned and covered with a waterproof material.

While your in the transmission area, look for a 7 foot coil of wire on top , with a data connector on the end, grey with a cap, Freightliner supplied it with the chassis harness and Newmar was to locate it. Didn't get done , I ran mine up the trans dip stick tube and hung it inside the engine rear cover .
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
HWH HOT Wire OC Bill Newmar Owner's Forum 3 07-16-2015 08:19 PM
Unknown wire Swright Travel Supreme Owner's Forum 8 06-12-2015 07:26 PM
Smoking wire gnsgn1 Vintage RV's 36 09-07-2014 10:48 PM
4 wire wiring quick question Usroverdrive Toads and Motorhome Related Towing 3 05-11-2014 04:21 PM
Question about battery bank system and length of wire to purchase Jasper7821 RV Systems & Appliances 9 01-24-2014 02:48 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:15 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.