Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 11-15-2015, 08:55 AM   #1
Junior Member
Join Date: Sep 2015
Posts: 6
Windshield squirters

My wipers work but pump for squirters and wipers under this control button does not work. It is an 06 Dutch Star.

Friedest is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-15-2015, 10:18 AM   #2
Senior Member
dennis45's Avatar

Join Date: Jun 2012
Location: BC
Posts: 4,681
Are you talking about the button on the Smart Wheel that turns on the Winshield Washers?

Dennis & Carol
2003, 4006, 41' DutchStar, Spartan, ISC 8.3L W/BanksPower - 2013 Honda CRV, BlueOx Baseplate, Aventa Bar & Patriot Brake. And the 04 Bird, Sunshine Car.
dennis45 is online now   Reply With Quote
Old 11-16-2015, 07:00 AM   #3
Senior Member
luvlabs's Avatar
Tiffin Owners Club
Join Date: Feb 2012
Location: Las Cruces, NM
Posts: 1,477
Pull the pump off and take it to a NAPA store. There is probably a replacement that will fit as these are usually automative based.
Roger & Mary
2014 Tiffin Phaeton 36GH
2012 Honda Fit toad
luvlabs is offline   Reply With Quote
Old 11-16-2015, 07:35 AM   #4
Senior Member
Luckiest Dreamer's Avatar
Winnebago Owners Club
Join Date: Jun 2010
Location: Iowa
Posts: 1,178
You say the pump dose not work. Are you sure the pump is bad or is the tiny orfice that aims the stream to the windshield plugged? Maybe the small rubber hose the should be connected to the pump has fallen off or broken. Is the power source that comes from that switch still connected to the pump or does the pump require a fuse? Is the switch good?Does the washer fluid container have fluid in it? Is there a filter on the hose that draws the fluid from the tank plugged or is there even a filter in the system.
It is a simple system, but it sounds as though troubleshooting would be in order before removing the pump with the expectations that is the problem.
Larry B, Luckiest Dreamer
Luckiest Dreamer is offline   Reply With Quote
Old 11-16-2015, 07:44 AM   #5
Senior Member
Join Date: Feb 2010
Posts: 4,278
If you used plain water they may be clogged.

Have helper operate button while you listen near tank for pump.

If pump is running remove hoses to check flow.

If pump not running check for voltage.

Common is clog.

May be blown fuse or bad switch.

If pump is not built into tank then generic replacement is easy.

If built into tank then slightly more work as the source auto needs to be determined so take it with you to napa
Tony & Lori
1989 Country Coach Savannah SE
TQ60 is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dropped By Insurance After Windshield Crack? Chris Travels Class A Motorhome Discussions 14 10-24-2015 10:07 AM
Windshield information ruffian Class A Motorhome Discussions 2 04-20-2015 07:54 PM
MCD Windshield Shade Install MandG-Fun Monaco Owner's Forum 3 12-27-2014 03:18 PM
Windshield Woes DWB Travel Supreme Owner's Forum 9 11-24-2014 02:23 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:56 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.