RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-07-2016, 01:32 PM   #1
Junior Member
 
Join Date: Feb 2014
Posts: 6
Windshield Washer Reservoir not working

My fellow Newmar DutchStar owners:

I own a 2015 Newmar DutchStar model 4369 (all electric). I had a front windshield replacement whereby the windshield arms and water reservoir hoses were disconnected. When all the work was completed my windshield water reservoir does not work. Anybody have any suggestions on how to trouble shoot this problem?

Thanks to all Newmar owners for your input! A wealth of information out there.
__________________

BSO 5458 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-07-2016, 04:31 PM   #2
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 19,922
When you say the "reservoir does nt work." Do you mean it won't hold washer solution, the pump fails to pump, or the solution doesn't hit the windshield?

If it's the pump, it could be a fuse in with the other chassis functions, a loose wire, or a failed pump motor. Check for 12v at the pump leads, making sure there's a good ground connection.

If the pump runs but the solution doesn't spray, you might still have a disconnected hose or it could be kinked, preventing flow.
__________________

__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Old 12-07-2016, 10:58 PM   #3
Senior Member
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 18,381
What did the replacement company say about this?
__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA IN 1SG 11B5MX,Infantry retired;Good Sam Life member,FMCA." My fellow Americans, ask not what your country can do for you, ask what you can do for your country. John F. Kennedy
Ray,IN is offline   Reply With Quote
Old 12-07-2016, 11:21 PM   #4
rpk
Senior Member
 
rpk's Avatar
 
Join Date: Apr 2001
Location: Hood River, OR
Posts: 121
Replaced a bad pump (easy to find at NAPA), no flow to windshield. Disconnected tubing that feed into wiper, applied a little air backwards, everything works fine.

Good luck
__________________
3126B Cat pushing 38' Harney Renegade. 2000 Civic toad. Retired submarine captain, 36 years Navy. Homeport is Black Hills SD.
rpk is offline   Reply With Quote
Old 12-08-2016, 12:55 AM   #5
"Formerly Diplomat Don"
 
Dutch Star Don's Avatar
 
Newmar Owners Club
Join Date: Apr 2005
Location: Moorpark, Ca.
Posts: 14,512
The washer pump that Newmar used is notorious for failing. There is a post in the Newmar Owners Forum that gives the Napa part number. I looked for the thread, but for some reason, search words won't come up. Along with the Napa part number, one of the posters used a one way valve to keep the water from draining back. I added the valve and new pump to mine, it works great.
__________________
Don & Mary
2019 Newmar Dutch Star 4018
2016 GMC Canyon 4WD Crew Cab
Dutch Star Don is offline   Reply With Quote
Old 12-08-2016, 06:23 AM   #6
Senior Member
 
ScottyBye's Avatar
 
Join Date: Jul 2013
Location: Calgary, Alberta, Canada
Posts: 599
Quote:
Originally Posted by Dutch Star Don View Post
The washer pump that Newmar used is notorious for failing. There is a post in the Newmar Owners Forum that gives the Napa part number. I looked for the thread, but for some reason, search words won't come up. Along with the Napa part number, one of the posters used a one way valve to keep the water from draining back. I added the valve and new pump to mine, it works great.


Windshield washer pump burnt out on 2015 Ventana

Post #19 shows the Napa replacement part #
__________________
2008 Fleetwood Southwind 36D
8.1L Vortec Gas with 5SP Allison Tranny
W-24 Workhorse Chassis
ScottyBye is offline   Reply With Quote
Old 12-08-2016, 10:27 AM   #7
"Formerly Diplomat Don"
 
Dutch Star Don's Avatar
 
Newmar Owners Club
Join Date: Apr 2005
Location: Moorpark, Ca.
Posts: 14,512
Thanks "ScottyBye" for finding the post. Here is the one way valve I added https://www.amazon.com/dp/B00FAM6EYE

My wipers have worked great since and no delay waiting fro water to pump up to the blades, especially if you don't use them very often.
__________________

__________________
Don & Mary
2019 Newmar Dutch Star 4018
2016 GMC Canyon 4WD Crew Cab
Dutch Star Don is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield Washer Fluid Reservoir abaerga MH-General Discussions & Problems 7 04-11-2014 06:01 PM
Windshield washer reservoir replacement NavlAv8r Fleetwood Owner's Forum 4 10-03-2010 10:34 PM
Need windshield washer reservoir cap GerrySr Winnebago Industries Owner's Forum 2 06-14-2009 08:06 PM
Where's the windshield washer reservoir? Clarence Zaitz Fleetwood Owner's Forum 2 06-28-2008 07:36 AM
Windshield Washer Fluid Reservoir? FrankO Winnebago Industries Owner's Forum 5 05-05-2007 07:23 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:33 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×