Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-26-2011, 07:53 AM   #1
Junior Member
 
Join Date: Jun 2011
Posts: 2
windshield wiper problems

i have an 07 Adventurer with windshield wiper problems. when they are running they are very loud and the controls do not work. it appears the motor overheats and shuts off in whatever positon it wants. they will run for about 10 minutes before stopping. i have tried running them for several minutes and shutting them off however the controls do not work and they run till they overheat.
has anyone had this expeience before?
__________________

__________________
bobneedshelp is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-26-2011, 12:36 PM   #2
Senior Member
 
jeepfreak's Avatar
 
Join Date: Mar 2003
Location: Home is where we park it
Posts: 417
Is this a Workhorse chassis? If so go the workhorse forum (just scroll down till you get to it) and do a search as there is much posted about this issue.
__________________

__________________
2007 Allegro 34wa .WH w20 8.1 6speed. Bow tie powered 79 CJ7 or a 2014 Jeep Unlimited Rubicon Toad.
jeepfreak is offline   Reply With Quote
Old 06-27-2011, 04:57 AM   #3
Junior Member
 
Join Date: Jun 2011
Posts: 2
Thanks I will look into ths information.
__________________
bobneedshelp is offline   Reply With Quote
Old 06-28-2011, 10:29 AM   #4
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 4,384
I found a lot of problems with grounds on the wipers. Remember you have a lot of fiberglass on the front. most manuf. run a ground wire to the wiper motor. If that wire gets loose, you will have have a problem with low voltage and high amps. This will cause a lot of heat.
__________________
1998 Pace Arrow 35 ft. F53 Ford V10 2012 Honda Civic toad
32 years mechanic at Delta Air Lines 15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is offline   Reply With Quote
Old 06-28-2011, 11:04 AM   #5
Senior Member
 
mccsix's Avatar
 
Ford Super Duty Owner
Join Date: May 2010
Location: Pensacola Fl
Posts: 667
I've had a lot of trouble with wipers on 2 new coaches. All problems/solutions centered on water getting into the connectors and grounding them out. None of the connectors were wx pac type and were positioned vertically to ensure water would get into them and stay there. I adjusted them to sit horizontal and sealed them with silicone...end of problem.
__________________
mccsix is offline   Reply With Quote
Old 09-07-2011, 10:49 AM   #6
Junior Member
 
Join Date: Sep 2011
Posts: 1
We're still having problems with our wipers -- won't work in the rain (isn't that when we need them?) We've replaced the motor with a new one just a few months ago, but still have the problem. Anyone have any suggestions? No one seems to be able to help us.
__________________

__________________
BAnspaugh is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield Wiper Overtravel Dennis Fineran Newmar Owner's Forum 22 05-24-2014 12:30 AM
Driver’s windshield wiper hangs up on the left side at speeds over 35MPH. SteveOGilroy Damon 19 09-03-2013 03:24 PM
One Piece Windshield Wiper Arms gjstacy Alpine Coach Owner's Forum 11 02-19-2011 06:02 PM
Windshield problems Uncle Sam Gulf Stream Owner's Forum 11 10-25-2008 01:23 PM
Ventana Windshield Wiper Ineffectiveness on a One Piece Windshield Spikester Newmar Owner's Forum 3 10-11-2008 07:44 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:55 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.