Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-11-2015, 11:04 PM   #1
Junior Member
 
Join Date: Aug 2015
Posts: 2
Wiring Problem

I own a 2003 Beaver Santiam. My problem is the left rear turn signal doesn't work. I've tested the bulb which was OK and checked the wiring with a meter. The right side marker light works and the front left signal works.
__________________

__________________
Pathof is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-11-2015, 11:22 PM   #2
"Formerly Diplomat Don"
 
Dutch Star Don's Avatar
 
Newmar Owners Club
Join Date: Apr 2005
Location: Moorpark, Ca.
Posts: 9,290
On motor homes, they're typically fused. A fuse for both right and left turn signal. Check your "run bay" for fuses.
__________________
Don & Mary
2014 Newmar Dutch Star - All Electric - 450 ISL
2016 GMC Canyon 4WD Crew Cab
Dutch Star Don is offline   Reply With Quote
Reply

Tags
wiring



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wiring problem at rear hitch plug. Stump Jumper Toads and Motorhome Related Towing 14 06-21-2015 10:35 PM
HWH Problem TsuSM70 iRV2.com General Discussion 6 05-23-2015 11:30 AM
2005 Gulf Stream Atrium w/ wiring problem. suebythelake Class A Motorhome Discussions 3 04-07-2015 05:24 PM
Unusual Hydro Hot problem, and the fix Medico RV Systems & Appliances 0 02-14-2014 07:18 AM
Redneck 1993 Allegro Bay Diesel Pusher with electrical problem jcruce13 Class A Motorhome Discussions 7 10-09-2013 12:27 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.