Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 07-15-2013, 07:33 PM   #1
Senior Member
Tiffin Owners Club
Join Date: Jun 2008
Posts: 584
Xantrex inverter/charger shows full charge at 12.2V

I have a Xantrex RV3102GS inverter / charger (with Xantrex RC/GS remote control panel) and it's working fine except that charging doesn't work great. At around 12.2V it's showing 'batteries full' and will only charge in 'float mode' and at around 11.5V is only charging in 'absorbtion mode'.

I'm hoping there's something I can adjust to tell it that 13V is 'batteries full' so that it goes into 'bulk', 'absorption' and 'float' modes properly. Max charge rate on the panel is set to 100%.

Thanks for any help.

michelb is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-15-2013, 08:51 PM   #2
Senior Member
docj's Avatar
Join Date: May 2011
Posts: 3,235
My Xantrex charger went bad a few months ago and exhibited the sort of symptom you are describing. I called customer service and they suggested disconnecting everything at the battery terminals and leaving it that way for ~10 minutes. After doing that the Xantrex went back into normal operation, for a few weeks, at least.

Sandie & Joel (RVParkReviews admin)
2000 40' Beaver Patriot Thunder Princeton CAT C-12
Follow us at http://www.facebook.com/WeissTravels.net
docj is online now   Reply With Quote
Old 07-16-2013, 05:33 PM   #3
Senior Member
Ray,IN's Avatar
Join Date: Aug 2001
Location: North America somewhere
Posts: 12,300
My RS2000 has user-adjustable parameters for the batteries. What does your owners manual say about the charger?
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA 1SG, retired;PPA,Good Sam Life member."We the people are the rightful masters of both the Congress and the Courts - not to overthrow the Constitution but to overthrow men who pervert theConstitution. "Abraham Lincoln"
Ray,IN is offline   Reply With Quote
Old 07-16-2013, 06:04 PM   #4
Senior Member
Tiffin Owners Club
Join Date: Jun 2008
Posts: 584
Thanks for all the suggestions. As usual, turns out that the simplest solution worked - I looked in the manual on how to adjust the voltage where it goes to bulk, absorbtion, float and didn't find anything but the next chapter mentioned that the battery temperature automatically adjusted voltage so I decided to try that and disconnected the battery temp sensor and sure enough, that fixed my problem. Batteries weren't charged or used much so I'm guessing my sensor failed.
michelb is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Full timing earlier than planned Trekkers Full-Timers 14 03-09-2014 03:13 PM
Finally ordered the full Banks Power Pack system Thor3650 Class A Motorhome Discussions 14 09-30-2013 09:00 AM
TrueLevel 1/3 full - all tanks pvictor189 RV Systems & Appliances 1 07-05-2013 08:18 PM
Entegra - Six Months Today Full Time DSL417 Entegra Owner's Forum 4 06-29-2013 11:56 PM
Xantrex AGS lights on Remote and Controller deandec Class A Motorhome Discussions 1 06-12-2013 09:40 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:24 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.