Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-03-2012, 10:34 AM   #1
Senior Member
 
Jchet's Avatar
 
Join Date: Apr 2012
Location: Clermont fl
Posts: 182
Yet another problem surfaced AC related!

We have 2 Duo Therm (Penquin) by Domestic AC units on our MH. The rear AC unit now has a motor that turns on at will with a loud humming sound, this motor will turn on without the AC compressor. When the compressor also kicks on it cools as it should and works fine, then the compressor turns off this loud humming continues. This happens if I turn the unit off entirely from the thermostat, this motor will still kick on and make a loud noise. It does turn off for awhile but it's tough to deal with at night. When it does turn off it makes a loud "clunk" sound. It has been working fine this whole trip and just developed this problem about 4AM today. Help!
__________________

__________________
J.Chet USAF LTC Retired
Teddy & Bella (Soft Coated Wheaten's)
Jchet is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-03-2012, 12:30 PM   #2
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 26,792
Have you been on the roof with cover off to observe what maybe going on?
May have a deceased visitor that needs to be cleaned out or bearings need a drop of oil..
__________________

__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 09-03-2012, 06:11 PM   #3
Senior Member
 
Jchet's Avatar
 
Join Date: Apr 2012
Location: Clermont fl
Posts: 182
Seems to have stopped doing it, it's probably waiting until we go to bed.
__________________
J.Chet USAF LTC Retired
Teddy & Bella (Soft Coated Wheaten's)
Jchet is offline   Reply With Quote
Old 09-03-2012, 06:33 PM   #4
Registered User
 
Vintage RV Owners Club
Gulf Streamers Club
Join Date: Oct 2010
Location: Indiana
Posts: 4,954
AC's or Heat pumps?
__________________
Midniteoyl is offline   Reply With Quote
Old 09-04-2012, 01:24 PM   #5
Senior Member
 
calhyatt's Avatar


 
Newmar Owners Club
Freightliner Owners Club
Join Date: Mar 2012
Location: Weston, Fl.
Posts: 914
Sounds like the compressor is still running. Fan motors don't clunk when they shut off but compressors do. Take off the cover on the airconditioner and observe if the condensor fan is running, if not and you still hear and feel a motor running, your compressor is still running. Might be the relay on the control board sticking on. Be careful while on the roof and take care. Seeya on the road..
__________________
2003 Newmar Kountry Star 3905, Freightliner XC chassis with CAT 330. Winnie the black lab, pretty Airbus captain wife, retired airline pilot with 11 grandkids. UH-1 pilot (Huey) U.S. Army 1967-1983. RVN 68-69. Northern Idaho my summer home.
calhyatt is offline   Reply With Quote
Old 09-04-2012, 01:43 PM   #6
Registered User
 
Vintage RV Owners Club
Gulf Streamers Club
Join Date: Oct 2010
Location: Indiana
Posts: 4,954
.. could be that 'low fan' is broke and when you actually hear it is when its in 'high'..
__________________

__________________
Midniteoyl is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:56 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.