Go Back   iRV2 Forums > MOTORHOME FORUMS > Class B Motorhome Discussions
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 12-07-2012, 08:04 AM   #1
Junior Member
Join Date: Sep 2012
Posts: 10
need help with generator

I have a 2008 Itasca Navion. New to rving. The generator starts and runs but there is no power to the tv, fridge, microwave etc. what am i doing wrong?

dianebernie is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-07-2012, 08:29 AM   #2
Junior Member
Winnebago Owners Club
Ford Super Duty Owner
Join Date: Aug 2012
Location: West Seneca, NY
Posts: 3
Hi and welcome......on the gen set check to make sure the circuit
breaker is on, also, any breakers for 110ac should be on inside the
coach....happy trails

grichs is offline   Reply With Quote
Old 12-07-2012, 08:55 AM   #3
Senior Member
Join Date: May 2011
Location: Port Dover, Ontario
Posts: 189
Your unit may not come with an automatic transfer switch. Look for a receptacle in the cable bay and plug the shore power into this and then start the generator.
harris155 is offline   Reply With Quote
Old 12-07-2012, 10:17 AM   #4
Senior Member
MartinP's Avatar
Rexhall Owners Group
Join Date: Aug 2012
Location: Merrill, Oregon
Posts: 513
The Generator may have monentary on re-set switch located near the circuit breakers, if it does, re-cycle the switch. Not sure on your setup bout you need check if you are getting 110 volts at the power center.

Martin Picke'
1998 Rexhall Anthem 34' DP, Cummins ISB, Allison 5 speed, Spartan Chassis, 300 watts solar.
MartinP is offline   Reply With Quote
Old 12-08-2012, 03:31 AM   #5
Junior Member
Join Date: Nov 2012
Posts: 9
Try Itasca's web site for an Onwer's manual. If no luck try Google, you may have to pay a couple bucks from the commercial sites, but it should worth it.
NeilMace is offline   Reply With Quote
Old 12-08-2012, 05:34 AM   #6
Junior Member
Join Date: Sep 2012
Posts: 10
thanks everyone. the switch was off. everything is ok now. appreciate all your help!

dianebernie is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:38 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.