Go Back   iRV2 Forums > MOTORHOME FORUMS > Class B Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-18-2014, 03:47 PM   #1
Junior Member
 
Join Date: Sep 2014
Posts: 7
Problems w/2800 onan gas generator starting it

Hey guys since I bought my van Ive had problems with my generator. I will number the issues for you guys.

1. The geneator will not start from inside the coach, but it will turn off from inside the coach.

2. The previous owner told me that I would have to start the generator from the outside and pull the throttle while I push start, and that way it does start.

3. Im not sure if its a bad carb, the coach was sitting for 5 yrs and has only 50 hrs on generator, by looking at the model of the genset its supposed to be a 2002 model.

4. I was able to start the genset and run the rooftop ac and microwave for 2 days with no problems and even run them both at same time.

5. Since this small engine boat lawnmower guy tried to work on my genset starting problem he cleaned the carb and adjusted the governer or throttle, the thing that im pulling with my right hand, he adjusted it with a screwdriver tighting or loosening some screw near it, since then the genset will not stay on when i put the ac lo cool or hi cool option or micowave, if i put those on it shuts off right away. It does stay on for a few mins when i just turn on the fan option on the rooftop ac., maybe 5 or 10 mins.

6. So in a nutshell i need to know what i need to do to fix the starting problem and what i need to do to get it back to the right frequency voltage so it can run my rooftop ac microwave etc.

I have attached a video link to youtube and pics of the genset from photobucket,

http://s1382.photobucket.com/user/marsha........o=0&_suid=14136647260190689879265138 8945

20141015_181906_zpsc06btayg.jpg Photo by marshallkhamou88 | Photobucket
http://s1382.photobucket.com/user/marsha........o=2&_suid=14136647867710700731668567 6423
20141015_181906_zpsc06btayg.jpg Photo by marshallkhamou88 | Photobucket
__________________

__________________
ASYRIANELVIS is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-19-2014, 07:32 AM   #2
Senior Member
 
94-Newmar's Avatar
 
Join Date: Nov 2009
Posts: 2,043
Please post the full model number of the generator.

As to the inability to START from the remote switch inside, it's most likely a corroded or broken start wire. The remote harness has two distinct start and stop wires running within it connected to the switch.

As to why it won't run... Since you're closing the throttle completely to get it to start and it's running at such a high RPM, I would suspect a huge vacuum leak exists somewhere between the outlet of the carb through the intake manifold horn.

Unfortunately, your model is unable to flash error codes upon any faults. I suggest removing the air cleaner and checking tightness of the 2 10mm bolts holding the carb to the intake horn. Do NOT overtighten them as you'll crack the aluminum flanges on the carb itself. I suspect that may have already happened which is what's causing the huge vacuum leak. If the bolts are already tight then I suggest removing the carb and inspecting the gaskets to/from the intake horn and checking the horn for any cracks in/near the area that it mates with the intake port.
__________________

__________________
94-Newmar Kountry Star 40-KSDP
Spartan/Cummins 8.3C-300HP/Allison 3060 WTEC-II/25yr RV Tech RVIA Certified/Onan-Cummins Certified
94-Newmar is offline   Reply With Quote
Old 10-19-2014, 01:35 PM   #3
Junior Member
 
Join Date: Sep 2014
Posts: 7
Quote:
Originally Posted by 94-Newmar View Post
Please post the full model number of the generator.

As to the inability to START from the remote switch inside, it's most likely a corroded or broken start wire. The remote harness has two distinct start and stop wires running within it connected to the switch.

As to why it won't run... Since you're closing the throttle completely to get it to start and it's running at such a high RPM, I would suspect a huge vacuum leak exists somewhere between the outlet of the carb through the intake manifold horn.

Unfortunately, your model is unable to flash error codes upon any faults. I suggest removing the air cleaner and checking tightness of the 2 10mm bolts holding the carb to the intake horn. Do NOT overtighten them as you'll crack the aluminum flanges on the carb itself. I suspect that may have already happened which is what's causing the huge vacuum leak. If the bolts are already tight then I suggest removing the carb and inspecting the gaskets to/from the intake horn and checking the horn for any cracks in/near the area that it mates with the intake port.
Thanks for the advice but Im not a mechanically inclined guy. I dont wanna get into it myself. If you look at the links on my photobucket account I took pictures of the generator and model number on it. Your advice kinda sounds a little complicated for me and to difficult to get into it by myself. But thanks neways man.
__________________
ASYRIANELVIS is offline   Reply With Quote
Reply

Tags
gas, generator, onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
7500 Onan generator problems klcracing Fleetwood Products Owner's Forum 7 08-14-2014 09:55 PM
Aux gas tanks burgiebill iRV2.com General Discussion 7 08-12-2014 11:16 AM
Onan 4000 Generator RVNYORKIE RV Systems & Appliances 2 07-17-2014 07:55 AM
Genny Gas line jastinjr Tiffin Motorhomes Owners Forum 11 06-30-2014 01:22 PM
EGR soot cleaning to have less replacement problems tom chelbana Cummins Engines 2 02-14-2014 09:09 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.