Go Back   iRV2 Forums > MOTORHOME FORUMS > Class B Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-25-2014, 06:07 PM   #1
Member
 
Join Date: Jun 2014
Posts: 42
Travato and Emergency Brake

When I release the emergency brake there is a beeping that goes on. It's like a headlight on reminder sound. The gear shift can be in any gear when this happens. I can pull the brake on to the first click and it stops. The brake light goes on but I don't believe the brake has really activated as there is no resistance when I start driving.

Just wondering if anyone else has experienced this and if so, how was it solved. I would rather solve it than go to the dealer.

Thanks for any help.
__________________

__________________
tjjeeper is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-25-2014, 09:39 PM   #2
Registered User
 
wincrasher's Avatar
 
Join Date: May 2001
Location: Greer, SC
Posts: 670
Hmmm. No, I haven't had that happen. Sounds like the cable needs adjusting. I'd go to a Chrysler dealer and not my RV dealer for this item.
__________________

__________________
wincrasher is offline   Reply With Quote
Old 06-26-2014, 08:28 AM   #3
Member
 
Join Date: Jun 2014
Posts: 42
Thanks for the reply Wincrasher. I am thinking it is either a cable adjustment or the e-brake switch which might think the brake is still on. Not sure if you know it or not but if anything is wrong with the Dodge portion, it has to go to a Business Link dealer for warranty repair. After the warranty expires any Dodge dealer can work on it.

Incidentally the unit is at the RV dealer to replace the Fairview propance regulator which just came in. When the switch in the unit was turned off, the propane was still on. The dealer discovered this when they did their predelivery inspection. Kudos to them for finding this.
__________________
2015 Pleasure-Way ProMaster Lexor TS
tjjeeper is offline   Reply With Quote
Old 06-26-2014, 09:05 AM   #4
Registered User
 
wincrasher's Avatar
 
Join Date: May 2001
Location: Greer, SC
Posts: 670
Good info. How do you find a Business Link dealer?
__________________
wincrasher is offline   Reply With Quote
Old 06-26-2014, 03:53 PM   #5
Junior Member
 
Winnebago Owners Club
Join Date: Jun 2014
Location: Ocean View, De.
Posts: 8
We've had our alarm go off in regard to parking break. We stopped, then brought the break all the way up and then all the way back down to release it and the alarm went off! Hopes this helps.
__________________
shcpostal is offline   Reply With Quote
Old 06-26-2014, 05:24 PM   #6
Member
 
Join Date: Jun 2014
Posts: 42
Wincrasher, I called the Dodge Customer Assistance at 1-800-992-1997, and they found a Business Link dealer near my zip code. There is also a Promaster number that is1-866-726-4636.

I have a Jeep Wrangler and my Jeep dealer is a couple of miles away and they are really good and know Jeeps. I was disappointed that the can't do warranty work. However, when it is out of warranty they will work on it. At least my Jeep dealer can change the oil.
__________________
2015 Pleasure-Way ProMaster Lexor TS
tjjeeper is offline   Reply With Quote
Old 06-26-2014, 05:26 PM   #7
Member
 
Join Date: Jun 2014
Posts: 42
Shcpostal, thanks for the reply. I have tried what you suggested. It started when I was parked and ready to drive it. I just pulled the brake handle up one click and it stops, shouldn't be enough to apply the brake. In fact in Drive I don't feel any resistance of the brakes. I'll drive it that way to the dealer.
__________________
2015 Pleasure-Way ProMaster Lexor TS
tjjeeper is offline   Reply With Quote
Old 06-28-2014, 08:19 AM   #8
Senior Member
 
gonational's Avatar
 
Winnebago Owners Club
Join Date: Oct 2012
Location: The Villages, Florida
Posts: 169
tjjeeper,,,,hi there, we experienced the alarm and believe or not when our alarm was going off and we couldn't shut it off I pulled up on the emergency brake a little and it went off .... but guess what wincrasher wrote about the alarm and it turned out to be the passenger seat position alarm.. when you turn the key on if your seats aren't back into the forward position your alarm will ring...that said the solution is to reach under the front of the seat (its really very easy) and squeeze the two plastic sensors together as far as you need to until the alarm shuts off...I hope this is your problem. then once you know how to do it you can have the wife squeeze it each time it goes off or you can take it in and get it adjusted. there is a thread by wincrasher that has pics of the problem area.
__________________
Jerry and Teri Lea
The Villages, Florida
2013 Winnebago Travato as of May 20th, 2014
gonational is offline   Reply With Quote
Old 06-28-2014, 08:49 AM   #9
Member
 
Join Date: Jun 2014
Posts: 42
gonational, thank you for your input. I found the post by wincrasher on the sensors. I will try squeezing them together and if I or my wife have to keep doing that, I will drill out the rivets reposition one of them and use screws. I might just elongate the holes to have more adjustment.
__________________
2015 Pleasure-Way ProMaster Lexor TS
tjjeeper is offline   Reply With Quote
Old 07-14-2014, 08:14 AM   #10
Member
 
Join Date: Jun 2014
Posts: 42
I fixed that darn beeping sound and the alignment problem of the sensors. It was an easy fix, I disconnected the wires on the sensor.
__________________

__________________
2015 Pleasure-Way ProMaster Lexor TS
tjjeeper is offline   Reply With Quote
Reply

Tags
brake



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:51 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.