RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Freightliner Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-01-2010, 07:53 AM   #1
Member
 
sam-tip's Avatar
 
Join Date: May 2009
Posts: 86
All dash instruments stuck not responding

I have a 2008 Winnebago Tour. Twice now the instrument panel has frozen. The tack and speedometer frozen in position. I would stop and it would say I am going 65mph at 1500 rpm. The odometer stopped. The turn signals and brakes lights worked but did not display on the dash.
I turned coach off and the lights on the display stayed on and the instruments remained frozen. I disconnect all the batteries and the display would reset and everything works fine. This time it took me awhile to realize I was not doing 65. Good thing the Garmin displays speed.
__________________

sam-tip is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-01-2010, 11:01 AM   #2
Senior Member
 
ernieh's Avatar
 
Join Date: Jul 2009
Posts: 1,125
Quote:
Originally Posted by sam-tip View Post
I have a 2008 Winnebago Tour. Twice now the instrument panel has frozen. The tack and speedometer frozen in position. I would stop and it would say I am going 65mph at 1500 rpm. The odometer stopped. The turn signals and brakes lights worked but did not display on the dash.
I turned coach off and the lights on the display stayed on and the instruments remained frozen. I disconnect all the batteries and the display would reset and everything works fine. This time it took me awhile to realize I was not doing 65. Good thing the Garmin displays speed.
Since your engine appears to be working normally, my guess would be either the computer itself or computer output to the instruments.
__________________

__________________
ernieh
2012 Phaeton 36QSH
2007 Wrangler Toad
ernieh is offline   Reply With Quote
Old 06-01-2010, 03:43 PM   #3
Senior Member
 
Join Date: May 2007
Location: Indiana
Posts: 471
Sounds like a trip to Freightliner is necessary. Check to make sure your 3-year warranty is still in force. Good Luck, Indiana Journey
indiana journey is offline   Reply With Quote
Old 06-01-2010, 06:15 PM   #4
Registered User
 
Join Date: Feb 2008
Posts: 266
Call the Freightliner Help line during normal business hours and tell the tech what you have. They'll put you on the right track. Most failures of the data line to the instruments causes them to go to zero, so your issue may be easy to diagnose.

John
Pigman is offline   Reply With Quote
Old 06-03-2010, 02:27 PM   #5
Senior Member
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Aug 2006
Posts: 1,500
1-800-FTL-HELP. They are 100% on call backs if you don't reach someone. If I remember correctly there is a sequence of buttons to push to zero and span your instruments.
MaverickBBD is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone change the tv location from below the dash to above the dash??? Born2RV MH-General Discussions & Problems 11 03-14-2010 02:53 PM
Electrical, no dash instruments or gauges STUFRAT Freightliner Motorhome Chassis Forum 4 10-14-2009 01:23 PM
2000 Winnebago 35U Squeaky Dash David Kanoy Winnebago Industries Owner's Forum 7 04-03-2009 05:16 AM
Dash Gauge Light Problem BIGRED1 Monaco Owner's Forum 1 10-01-2006 04:07 PM
Dash A/C Repair - Need some sage advice chasfm11 MH-General Discussions & Problems 11 11-06-2005 01:18 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.