RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Freightliner Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-11-2018, 11:30 AM   #1
Junior Member
 
Join Date: Oct 2018
Posts: 4
Instrument cluster dead

I have a 2018 Tiffin Phaeton on a Freightliner chassis. A couple of weeks ago the instrument cluster froze. The speedometer stuck at 62mph, the tack froze, the fuel gauge froze and the air gauges dropped to zero. After I stopped the coach, shut down the engine and restarted it, things returned to normal. I called the dealer, who suggested that there might be a loose ground or loose relay. I found a loose relay that I thought might be the culprit and pushed it back in.

I used the coach on a short trip with no problems.


Unfortunately, the problem has returned. This time the speedometer jumped to full deflection and then returned to the speed I was doing and stuck there. I then noticed that the air pressure, battery, fuel all read zero. The tach and speedometer were stuck at 62mph and 1700 rpm. I have rechecked the bus bars and relays and fuses, but canít find anything loose.

Can anyone think of something that I can check, or any suggestions on what the problem might be.

Many thanks
__________________

Flyboy01 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-11-2018, 02:14 PM   #2
Junior Member
 
Join Date: Sep 2018
Posts: 1
I and many others have the same problem. Mine is a 2007 Damon on a F/L chassis. I took the motor home to a Freightliner service center but they could not fix the problem After talking to Freightliner custom chassis I purchased up graded jumper cables and fitted them. From that point on the gauges started to work with intermittent shut downs. Then it poured down while travelling and once again they shut down for several hundred miles. I am going to start with checking for any loose electrical connections and apply di-electric grease.
__________________

Tommo nz is offline   Reply With Quote
Old 10-25-2018, 04:02 PM   #3
Senior Member
 
Damon Owners Club
Join Date: Feb 2015
Location: North Florida
Posts: 347
I have the same issue what did you find to be the problem tommo
__________________
Mark & Shana Miller
2008 Tuscany 4072 DP
Go Gators
markmiiler is offline   Reply With Quote
Old 11-13-2018, 09:08 AM   #4
Member
 
Roadwarrior7's Avatar
 
Tiffin Owners Club
Join Date: Mar 2018
Posts: 40
Tommo posted:
"I purchased up graded jumper cables and fitted them."

You must mean that you upgraded your battery cables?
Roadwarrior7 is offline   Reply With Quote
Old 11-13-2018, 12:21 PM   #5
kya
Junior Member
 
Join Date: Aug 2016
Location: R.I.
Posts: 15
I think he means the wires on the back of the gauges . freightliner daisy chains the gauges , they updated the wires to help solve this problem, it did not work on mine. They ended up replacing the LBCU unit and it worked for a trip out west then they stopped working again.. its going back into the repair facility again after thanksgiving... its a real pain in the A--.. when mine go out the only thing that works is the air pressure gauge.. the LBCU stays working so I can monitor vitals of engine & speed.. JUST no fuel gauge which make s thing a might interesting. my unit is a 2009 Freightliner chassis. coachman pathfinder DP.
kya is offline   Reply With Quote
Old 12-06-2018, 08:51 PM   #6
Junior Member
 
Join Date: Nov 2013
Posts: 6
What is a LBCU?
rexandrose is offline   Reply With Quote
Old 12-07-2018, 01:10 AM   #7
dp7
Senior Member
 
dp7's Avatar
 
Join Date: Oct 2016
Location: So Cal
Posts: 320
Quote:
Originally Posted by rexandrose View Post
What is a LBCU?
Light Bar Control Unit.
__________________
2017 Newmar Ventana 3709
2017 Jeep Wrangler (2 door)
dp7 is offline   Reply With Quote
Old 12-07-2018, 10:35 AM   #8
Junior Member
 
Join Date: Oct 2018
Posts: 4
Quote:
Originally Posted by Tommo nz View Post
I and many others have the same problem. Mine is a 2007 Damon on a F/L chassis. I took the motor home to a Freightliner service center but they could not fix the problem After talking to Freightliner custom chassis I purchased up graded jumper cables and fitted them. From that point on the gauges started to work with intermittent shut downs. Then it poured down while travelling and once again they shut down for several hundred miles. I am going to start with checking for any loose electrical connections and apply di-electric grease.
In the end, it turned out to be a loose ground on a bus bar.
Flyboy01 is offline   Reply With Quote
Old 12-08-2018, 05:49 AM   #9
Senior Member
 
Join Date: Oct 2016
Location: Rendon, Texas
Posts: 360
WE had a similar problem, and it too was a poor connection. Glad your problem is fixed.
__________________
May your smiles be many and the miles be plenty.

Karen & Allen Van Zandt
txcpl is offline   Reply With Quote
Old 12-09-2018, 12:17 PM   #10
Senior Member
 
Dfreiberger's Avatar
 
Tiffin Owners Club
Winnebago Owners Club
Fleetwood Owners Club
Holiday Rambler Owners Club
Join Date: Jun 2012
Location: Brock, Texas
Posts: 318
Mine went dead as well. I cycled off both the chassis and coach master power switches off for about three minutes and back on. All is good now for the last 6 months
__________________

__________________
Viv and Dutch Freiberger
2018 Tiffin Phaeton 40AH
Brock, Texas
Dfreiberger is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Phaeton dead instrument cluster Flyboy01 Tiffin Motorhomes Owners Forum 6 12-08-2018 08:42 AM
Workhorse Instrument Cluster Display Drifterpilot MH-General Discussions & Problems 19 04-23-2017 11:24 PM
Bounder: 97 Bounder Instrument Cluster Dead 2bassbuds Fleetwood Products Owner's Forum 4 01-22-2016 07:57 PM
Non Responsive - instrument cluster campercatz Workhorse and Chevrolet Chassis Motorhome Forum 34 01-15-2009 02:16 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.