Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Freightliner Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-21-2007, 03:45 PM   #1
Junior Member
 
Join Date: Mar 2003
Location: Orlando Florida
Posts: 17
My engine fan seems to run continuously which is not how the MBE is designed. A FL rep told me the fan disengages via a 12V signal when the engine temp is below about 200. Also, the engine fan will run continuously when you turn on the dash A/C, regardless of engine temp. What's the big deal you ask? About 40 ponies to drive the fan. I'd prefer to give the ponies a rest or at least not have to feed them if they're not needed, and to keep them in reserve. Have any MBE owners observed the radiator air blow by to determine when the fan is running or off. Mine runs from the startup whne coolant temp is 100 or less to shut down.
__________________

__________________
Jim, Malissa & Kids
Winter Springs (Orlando) Florida
Considering Allegro 35QBA & other bunk models
FloridaFitz is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-21-2007, 03:45 PM   #2
Junior Member
 
Join Date: Mar 2003
Location: Orlando Florida
Posts: 17
My engine fan seems to run continuously which is not how the MBE is designed. A FL rep told me the fan disengages via a 12V signal when the engine temp is below about 200. Also, the engine fan will run continuously when you turn on the dash A/C, regardless of engine temp. What's the big deal you ask? About 40 ponies to drive the fan. I'd prefer to give the ponies a rest or at least not have to feed them if they're not needed, and to keep them in reserve. Have any MBE owners observed the radiator air blow by to determine when the fan is running or off. Mine runs from the startup whne coolant temp is 100 or less to shut down.
__________________

__________________
Jim, Malissa & Kids
Winter Springs (Orlando) Florida
Considering Allegro 35QBA & other bunk models
FloridaFitz is offline   Reply With Quote
Old 08-22-2007, 08:42 PM   #3
Senior Member
 
vicsryd's Avatar
 
Join Date: Apr 2005
Location: Vancouver, Washington
Posts: 732
Send a message via Yahoo to vicsryd
For other readers reference I looked at your profile to see you have a 2007 Tiffin Phaeton QSH which per FL info is built on a version of the XCR chassis.

What the FL rep told you is my understanding as well. The default operation of the clutch when 12vdc is missing is on/engaged. Therefore, if it's always on I would assume you have an electrical problem in the wiring harness or the contact assembly to the clutch or maybe the ECM is not programmed correctly.

The 800-FTL-HELP customer service should open a warranty case for you and instruct you to take it to a FL Oasis dealer.

For what it's worth a different problem in this area is the source of a recall for 2007 and 2008 FL chassis MH's with Cummins engines with rear radiators and the fan clutch option. The problem seems to be a miscommunication between FL and Cummins about how to program the ECM. Basically, Cummins is turning off the 12vdc at 200 degrees instead of turning it on and causing the engine to overheat.
__________________
Vicki & Jon Pritchard
05 Journey 34H - CAT C7 - Toyota RAV4
3 doxies, 1 chihuahua - WIT, Escapees, FMCA

vicsryd is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boost gauge reading with MBE 926 RJRobb Freightliner Motorhome Chassis Forum 10 05-16-2009 10:41 PM
C7 fan clutch Jestme13 Freightliner Motorhome Chassis Forum 7 11-26-2007 11:47 AM
Clutch Fan RattlenRam Workhorse and Chevrolet Chassis Motorhome Forum 4 07-28-2007 05:45 AM
After-market Fan Clutch Teach Freightliner Motorhome Chassis Forum 4 10-23-2006 03:34 PM
Clutch Fan dicktater Workhorse and Chevrolet Chassis Motorhome Forum 3 07-22-2006 07:29 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:10 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.