Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Freightliner Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-29-2012, 03:47 PM   #1
Junior Member
 
abullit1's Avatar
 
Join Date: Apr 2011
Location: Las Vegas
Posts: 22
No 12 volt power to abs ecu

I have lost power to my abs ecu. I have checked all three fuse locations and i cant find any blown fuses.can anybody help me?
it is a 99 discovery 36t
__________________

__________________
99 Discovery 36T
275hp cummins 5.9
64000 mi
abullit1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-30-2012, 08:12 AM   #2
Member
 
OddOne's Avatar
 
Tiffin Owners Club
Join Date: May 2012
Location: Ponca, Ne
Posts: 34
Do you still have power to all other systems? (ie head lamps, pk lights, radio, starter and such)
__________________

__________________
OddOne is offline   Reply With Quote
Old 05-30-2012, 08:38 PM   #3
Junior Member
 
abullit1's Avatar
 
Join Date: Apr 2011
Location: Las Vegas
Posts: 22
Quote:
Originally Posted by OddOne View Post
Do you still have power to all other systems? (ie head lamps, pk lights, radio, starter and such)
yes everything works, abs light is on ,tested at ecu gray conector pin #1 and #2 should have 12v with key on.
__________________
99 Discovery 36T
275hp cummins 5.9
64000 mi
abullit1 is offline   Reply With Quote
Old 05-31-2012, 01:57 PM   #4
Member
 
OddOne's Avatar
 
Tiffin Owners Club
Join Date: May 2012
Location: Ponca, Ne
Posts: 34
It sounds more like an abs sensor has malfunction and the ecu shut down the abs system. Will need to scan the system and find the code for why the abs light is on.

Chris
__________________
OddOne is offline   Reply With Quote
Old 06-01-2012, 04:04 PM   #5
Junior Member
 
abullit1's Avatar
 
Join Date: Apr 2011
Location: Las Vegas
Posts: 22
Problem solved. ABS relay! Fyi there are two relays to the abs ecm they are located inside frame passenger side next to trans tail shaft. There are four relays in that location if dont know they are there you will never see them. Had to move hoses and wires. The two with red wires are to the abs.
__________________
99 Discovery 36T
275hp cummins 5.9
64000 mi
abullit1 is offline   Reply With Quote
Reply

Tags
power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.