Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Freightliner Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-26-2012, 06:50 PM   #1
Member
 
Winnebago Owners Club
Join Date: Aug 2010
Posts: 66
No power to dash or ignition

I have a 2003 Winne Journey DL on a Freightliner chassis with the Cat 330. Unfortunately, it has spent more time than I'd like parked instead of on the road. I'm trying to get it ready for the season but am experiencing a problem where there is no power to the dash or ignition when I turn the key. Both batteries are freshly charged reading about 13v. I've cleaned the terminals etc and checked the connections to the ground (somewhat difficult to get to). The interesting thing is when I hit the Auxilary power - using the coach batteries for a boost - everything lights up and starts. Once that occurs I can start off the chassis batteries without issue. When I let the rig sit for more than a few hours it goes back to dead.

To me, it acts like a relay is not energizing or maybe not being held in an energized state. Kicking it with the extra power from the coach batteries wakes it up and life is good - at least for a little while. I'll get the batteries checked, again, just to be sure but any thoughts?
__________________

__________________
Larry & Phyllis
Santa Fe, NM
2003 Winne Journey DL
lpasekof is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-27-2012, 05:47 AM   #2
Senior Member
 
rgreen45's Avatar
 
Join Date: Jun 2011
Location: Bradenton, Fl.
Posts: 703
Based simply on what you've said, I suspect a bad chassis battery disconnect switch or bad connections there.
__________________

__________________
Ray G.
ASE Master Med-Heavy Trucks
RVIA Certified
rgreen45 is offline   Reply With Quote
Old 05-27-2012, 11:52 AM   #3
Senior Member
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Aug 2006
Posts: 1,500
Give 1.800.FTL.HELP a phone call and they will walk you through a trouble shooting check list. If they don't answer right away, leave a call back number. They pride themselves on being 100% on call backs.
__________________
MaverickBBD is offline   Reply With Quote
Reply

Tags
dash, power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.