RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Entegra Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-22-2019, 06:54 PM   #1
Senior Member
 
pallencollin's Avatar
 
Join Date: May 2013
Location: Woodland, Washington
Posts: 767
Ď14 Anthem DEQ CLASSIC

Cummins Northwest Coburg completed an ECM update while in their shop for completion of the recent emissions recall.

While returning home, 135 miles, I discovered the MPG display under the odometer is displaying MPG 0.0 continuously. The instant MPG in another screen is working correctly along with all other information screens.

Has anyone else had this issue?
__________________

__________________
Peter & Kathy Collins
Woodland, WA
2014 Anthem 42DEQ
pallencollin is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-22-2019, 07:28 PM   #2
Senior Member
 
DoggieDaddy's Avatar
 
Join Date: Jul 2013
Location: Where ever we park it
Posts: 904
Quote:
Originally Posted by pallencollin View Post
Cummins Northwest Coburg completed an ECM update while in their shop for completion of the recent emissions recall.

While returning home, 135 miles, I discovered the MPG display under the odometer is displaying MPG 0.0 continuously. The instant MPG in another screen is working correctly along with all other information screens.

Has anyone else had this issue?

I did a reset of the MPG display once and it took a while for it to display a value. The computer is doing the math and needs a proper sample for the equation. Whatever field is being used to store the "fuel used" cannot be zero because it would create a divide by zero error.
__________________

__________________
Robert & Holly - "Fulltimers" 5+ years
Schnauzers Augie Doggie and Monty Puppy
2014 Anthem 44B Rad Copper/ 2013 Ford Explorer
DoggieDaddy is offline   Reply With Quote
Old 11-22-2019, 07:56 PM   #3
Senior Member
 
royals1212's Avatar
 
Entegra Owners Club
Join Date: Feb 2016
Location: Carrollton, TX
Posts: 946
Same thing happen to us on our 2015 Aspire. About 3 years ago and 15,000 miles ago we updated ours and it still hasnít reset to the actual mileage, showing abot 6 mikes to the gallon when we average 7.7 ish mpg. I read somewhere where the dash instrument panel need a software update to get to work with the ecm update.

Hopefully,someone who knows the solution will chime in.

Herb
__________________
Herb & Tanya
2015 Entegra Aspire 44U
2015 Jeep Sahara Unlimited
royals1212 is offline   Reply With Quote
Old 11-22-2019, 07:56 PM   #4
Senior Member
 
brobox's Avatar


 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 21,442
Did Cummins do an update on the engine computer? Might try the 12v reset. Robert could be correct if Cummins zeroed it out with an update.
__________________
Chuck in SW FL
A "Digital" 2019 Cornerstone "B"
A "Classic" 2014 Anthem 42 RBQ---Sold
2016 Colorado Z71 PU
brobox is offline   Reply With Quote
Old 11-23-2019, 09:58 AM   #5
Senior Member
 
royals1212's Avatar
 
Entegra Owners Club
Join Date: Feb 2016
Location: Carrollton, TX
Posts: 946
Yes cummins performed the ECM update and yes I have reset the chassis and coach 12 volt system. If I remember correctly, I talked to Spartan (the memory is questionable) and the said I would have to send the MIP (Main Instrument Panel) back for a software update. I decided it dinít bother me enough to go through the hassle.

Herb
__________________
Herb & Tanya
2015 Entegra Aspire 44U
2015 Jeep Sahara Unlimited
royals1212 is offline   Reply With Quote
Old 11-23-2019, 11:18 AM   #6
Senior Member
 
brobox's Avatar


 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 21,442
That happened on my 14 with the ECM update at Ocala Cummins on my way to our PDI. When I had my PDI done, Entegra still had the Spartan shop and they did the Spartan update which corrected the MPG reset. My MPG was fine, I just could not reset it after filling up. My experience, Cummins update sometimes change Spartan's.
__________________
Chuck in SW FL
A "Digital" 2019 Cornerstone "B"
A "Classic" 2014 Anthem 42 RBQ---Sold
2016 Colorado Z71 PU
brobox is offline   Reply With Quote
Old 11-28-2019, 12:59 PM   #7
Senior Member




 
Entegra Owners Club
Join Date: Jul 2015
Location: Central Florida
Posts: 436
Cool

I had the ECM updated in Phoenix a couple years ago and it didn't have any effect on my dash readouts. My coach was several updates behind...had never been updated since new. Now, when I visit Cummings for service, I always have them check for any updates. The update in Phoenix improved my fuel mileage and fixed a multitude of bogus Check Engine Lights.

But, that coach now belongs to someone else
__________________

__________________
2012 Entegra Anthem 42RBQ - Sold
2005 Beaver Monterey - Sold
2016 Jeep Cherokee
Dr. Q is offline   Reply With Quote
Reply

Tags
anthem



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anthem DEQ Checklist Wineman Entegra Owner's Forum 11 02-16-2014 08:35 AM
Anthem DEQ storage bays zman62 Entegra Owner's Forum 18 02-11-2014 06:24 PM
Looking at GVW - What does your Anthem DEQ GVW sticker say? hogdriver Entegra Owner's Forum 8 01-19-2014 08:10 PM
Close to pulling the trigger on an Anthem DEQ zman62 Entegra Owner's Forum 0 01-05-2014 03:07 PM
Pics of our Anthem DEQ being built. Wineman Entegra Owner's Forum 34 12-18-2013 11:15 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×