RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Entegra Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-10-2019, 03:29 PM   #1
Senior Member
 
dave&ginny's Avatar
 
Join Date: Feb 2012
Location: Peoria IL
Posts: 1,373
Bad Freeze Plug

Has anyone else had problems with a freeze plug?

I took the coach for a ride today and only made it about 8 miles before the ďcheck engine ď light and buzzer came on.

Thankfully I was real close to my office so we pulled in there. I found a hole in a freeze plug that looks like it was caused by corrosion. This really surprised me because Iíve only used the called for antifreeze. I hope this is covered by the Cummins warranty. If not I guess Iíll put a new one in myself
Attached Thumbnails
Click image for larger version

Name:	71897AD4-2FEE-4A5B-96E7-0CF5ED88C56F.jpg
Views:	60
Size:	321.7 KB
ID:	237537   Click image for larger version

Name:	4C071E9E-6984-480B-BD4C-4E7F785EFD2A.jpg
Views:	54
Size:	460.8 KB
ID:	237538  

__________________

dave&ginny is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-10-2019, 03:40 PM   #2
Senior Member


 
Join Date: Nov 2014
Location: Island Park , NY
Posts: 514
From the looks of that block and that freeze plug, i'd be planning on changing all of the accessible ones and pray the others hold up ! It will be cheaper than spraying antifreeze all over each time one goes! They make freeze plugs that have rubber and expand with a wrench might be the way to go with some that are blocked by other things , I have used them before and they work well if you clean the bore out first. Bobby
__________________

__________________
Sally, Bob and our 4 Legged friends!
88 Winnebago Chieftain - Winter Home of Bob our outside Cat
'06 Itasca Sunova 8.1/4l85e, retired 90 Dakota Convertible Toad, 2015 Kia Soul (SunovaToad)
FastGlassMan is offline   Reply With Quote
Old 03-10-2019, 03:43 PM   #3
Senior Member


 
Join Date: Nov 2014
Location: Island Park , NY
Posts: 514
Dave, looks like that front one was installed backwards??????????Bobby
__________________
Sally, Bob and our 4 Legged friends!
88 Winnebago Chieftain - Winter Home of Bob our outside Cat
'06 Itasca Sunova 8.1/4l85e, retired 90 Dakota Convertible Toad, 2015 Kia Soul (SunovaToad)
FastGlassMan is offline   Reply With Quote
Old 03-10-2019, 04:12 PM   #4
Senior Member
 
dave&ginny's Avatar
 
Join Date: Feb 2012
Location: Peoria IL
Posts: 1,373
After only 30,000 miles and 4 years, this really surprised me. I think the Cummins came with a 50,000 mile warranty but I'm not sure this is covered. The good news is the engine didn't overheat and I wasn't 1000 miles from home. This is just an inconvenience at this point.

Like I said before, I've always used the fluid that they recommend from the factory.
__________________
2015 Entegra Aspire RBQ
Pusher.. 2016 Ram Limited 2500 Crew Cab 6.7 diesel
Blue Ox Avail, Air Force One
dave&ginny is offline   Reply With Quote
Old 03-10-2019, 04:16 PM   #5
Senior Member
 
TurboDaveTX's Avatar
 
Monaco Owners Club
Entegra Owners Club
Spartan Chassis
Join Date: Mar 2011
Location: Dallas, TX
Posts: 475
Quote:
Originally Posted by FastGlassMan View Post
Dave, looks like that front one was installed backwards??????????Bobby


Looks backwards to me too.
__________________
F78957
2015 Entegra Cornerstone 45B - Cayenne
2016 Jeep Rubicon Unlimited,2014 Raptor
TurboDaveTX is offline   Reply With Quote
Old 03-10-2019, 05:35 PM   #6
Senior Member


 
Join Date: Jan 2016
Location: Montgomery, TX (Home Sweet Home)
Posts: 2,492
That plug is installed correctly, take a look at picture #2. Unless the plug is defective, it could have failed as a result of a coolant that has lost the correct chemical additive levels.

I would suggest you contact Spartan and obtain their current guidance regarding coolant change intervals. In addition, Cummins may be able to shine some light into this requirement.

Final Charge USED TO have an extender that could be added to their coolant to maintain the correct balance of chemical additives. I donít know if this is still available.

Over time, the coolant may maintain itís antifreeze properties, but will likely lose the other qualities that prevent liner pitting.

In short, coolant has a certain finite lifespan.

-Matt
__________________
Currently Motorhomeless
2017 Entegra Aspire 44R (bunks) towing 2019 F-350 LB (Sold)
2012 Tiffin Phaeton 40QKH (Our Phaeton was so nice, we bought it twice)
2016 Open Range RF376FBH (Sold)
Matt D is offline   Reply With Quote
Old 03-10-2019, 07:56 PM   #7
Senior Member
 
Gary.Jones's Avatar


 
Join Date: Oct 2012
Location: Louisiana
Posts: 6,317
Blog Entries: 1
Matt

Well, that is news to me. The container that the Peak Final Charge Extended Life Coolant (which is what is stocked by most stores (even WalMart)) is sold in has writing all over the front of the container which implies that the coolant can be used for like 500,000 miles. Maybe I need to read the fine print. Nothing is as good as any manufacturer says it is, but seriously............ ?

Gary
__________________
Gary and Dee, Zowie and Bowie (traveling cat sibs)
2019 Cornerstone 45B, X15-605hp, Imperial, Spartan K3,
2013 Honda CR-V toad, Demco Excali-Bar II,
Demco Baseplate, Demco Toad Light system, 73 de W5Fi
Gary.Jones is offline   Reply With Quote
Old 03-10-2019, 07:58 PM   #8
Senior Member
 
dave&ginny's Avatar
 
Join Date: Feb 2012
Location: Peoria IL
Posts: 1,373
Matt,

I understand what you're saying but I bought that coach in 2015 and a new radiator was installed at 15,000 miles around December of 2016. That means that coolant only has 15000 miles on it and a little over 2 years old.

I've maybe added a quart of Final Charge to it since the radiator was installed. The corrosion really has me baffled.
__________________
2015 Entegra Aspire RBQ
Pusher.. 2016 Ram Limited 2500 Crew Cab 6.7 diesel
Blue Ox Avail, Air Force One
dave&ginny is offline   Reply With Quote
Old 03-10-2019, 08:02 PM   #9
Senior Member
 
Gary.Jones's Avatar


 
Join Date: Oct 2012
Location: Louisiana
Posts: 6,317
Blog Entries: 1
Almost has to be a defective plug, right?

Gary
__________________
Gary and Dee, Zowie and Bowie (traveling cat sibs)
2019 Cornerstone 45B, X15-605hp, Imperial, Spartan K3,
2013 Honda CR-V toad, Demco Excali-Bar II,
Demco Baseplate, Demco Toad Light system, 73 de W5Fi
Gary.Jones is offline   Reply With Quote
Old 03-10-2019, 08:05 PM   #10
Senior Member
 
dave&ginny's Avatar
 
Join Date: Feb 2012
Location: Peoria IL
Posts: 1,373
Quote:
Originally Posted by Gary.Jones View Post
Almost has to be a defective plug, right?

Gary
This plug is easy to get to so the fix shouldn't be a problem. But these freeze plugs are all over the engine, which one will be next?
__________________
2015 Entegra Aspire RBQ
Pusher.. 2016 Ram Limited 2500 Crew Cab 6.7 diesel
Blue Ox Avail, Air Force One
dave&ginny is offline   Reply With Quote
Old 03-10-2019, 08:08 PM   #11
Senior Member
 
Gary.Jones's Avatar


 
Join Date: Oct 2012
Location: Louisiana
Posts: 6,317
Blog Entries: 1
Dave

You will, most likely, do what all the rest of us do....... Let the sleeping dog lie .... and pray that the OEM's final inspector was only dozing off for a few seconds... ....

Gary
__________________
Gary and Dee, Zowie and Bowie (traveling cat sibs)
2019 Cornerstone 45B, X15-605hp, Imperial, Spartan K3,
2013 Honda CR-V toad, Demco Excali-Bar II,
Demco Baseplate, Demco Toad Light system, 73 de W5Fi
Gary.Jones is offline   Reply With Quote
Old 03-10-2019, 08:21 PM   #12
Senior Member
 
Join Date: Nov 2015
Posts: 583
Dave, pop the bad one out and replace it with an expandable one, then pop another one out and examine it to determine if it is sound . Go from there .

Clifford
clifford j is online now   Reply With Quote
Old 03-10-2019, 09:56 PM   #13
Senior Member


 
Join Date: Jan 2016
Location: Montgomery, TX (Home Sweet Home)
Posts: 2,492
Gary, here is what I was talking about.. from Spartan.

Now, I think OWE may have discontinued the production of the Extender, and thus my recommendation to check with Spartan and Cummins regarding the effect upon the change interval.

I just happen to have a bottle of Extender, and had planned to use it when my coolant approaches the 36 month mark.

-Matt
Attached Thumbnails
Click image for larger version

Name:	86CBA906-1C33-4260-804D-44989C2C125E.jpeg
Views:	43
Size:	269.0 KB
ID:	237619  
__________________
Currently Motorhomeless
2017 Entegra Aspire 44R (bunks) towing 2019 F-350 LB (Sold)
2012 Tiffin Phaeton 40QKH (Our Phaeton was so nice, we bought it twice)
2016 Open Range RF376FBH (Sold)
Matt D is offline   Reply With Quote
Old 03-10-2019, 10:10 PM   #14
Senior Member
 
brobox's Avatar


 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 21,442
Dave you can purchase coolant test strip at Cummins for $1. It will show if the coolant is in balance. My local NAPA use to sell them individually, but now only sell them by the box. Your local NAPA might still sell them individually.
https://www.cumminsfiltration.com/eme/analysis
__________________

__________________
Chuck in SW FL
A "Digital" 2019 Cornerstone "B"
A "Classic" 2014 Anthem 42 RBQ---Sold
2016 Colorado Z71 PU
brobox is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Good SAM...Bad Sam Bad Bad Bad! STLNLUV iRV2.com General Discussion 43 12-17-2018 08:49 AM
Freeze Out Plug Issue on Cummins ISC 330 Diesel sstehman Cummins Engines 1 07-08-2016 08:47 PM
The drip from a freeze plug on a a brand new engine? Americanrascal Ford Motorhome Chassis Forum 23 05-23-2016 04:22 PM
Bad, bad, bad - bad vibrations.... Doc Vegas Ford Motorhome Chassis Forum 21 11-30-2014 06:56 PM
Cracked freeze plug Pellerotto Cummins Engines 32 04-06-2013 03:33 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:01 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×