RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Entegra Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-26-2017, 10:35 PM   #1
Senior Member
 
bamaspiveys's Avatar
 
Join Date: Oct 2016
Location: Murfreesboro, TN
Posts: 338
Generator starting issue

On the last two trips I could not start the generator from the dash switch or the EC30 switch. It would turn over and "almost" crank.

Each time I had to go outside and start it on the generator switch and it started just fine on the first try using the outside switch.

Any ideas?
Suggestions?
__________________

__________________
Michael & Wendy
2014 Entegra Aspire 42DEQ
2017 Chevy Tahoe Z71(hers)
2015 Jeep Wrangler Unlimited(his)
bamaspiveys is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-27-2017, 12:25 AM   #2
Senior Member
 
Ann n Gene's Avatar
 
Join Date: Apr 2004
Location: Stillwater, Ok
Posts: 4,352
Sounds like a bad ground or loose connection in the wiring run.
__________________

__________________
2019 Newmar New Aire
2017 Ford F150 King Ranch
Ann n Gene is offline   Reply With Quote
Old 08-27-2017, 06:35 AM   #3
Senior Member
 
Gasman 2's Avatar


 
Entegra Owners Club
Join Date: Jan 2015
Location: Caldwell , Ohio 43724
Posts: 1,096
There is a flat plug electrical connection at the top right corner of the generator. Pull the plug apart and Check for corrosion
__________________
Gasman 2
2016 Anthem 42 RBQ
Toad 2017 GMC Sierra 4X4
Gasman 2 is offline   Reply With Quote
Old 08-27-2017, 07:40 AM   #4
Senior Member
 
brobox's Avatar


 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 21,471
As Gasman said, it's about 80% of the remote starting problems. Clean the connectors with electrical contact cleaner, aplly a thing coat of die electric grease and tape the plug with weather proof tape. The plug is not the best weatherproof plug and it sits in front where it gets sprayed when driving in the rain. The flat plug is on the right of the generator, but left if you are looking at it.

It is a good preventive maintenance for others as the plugs do corrode, it's just a matter of when.
__________________
Chuck in SW FL
A "Digital" 2019 Cornerstone "B"
A "Classic" 2014 Anthem 42 RBQ---Sold
2016 Colorado Z71 PU
brobox is offline   Reply With Quote
Old 08-27-2017, 07:45 AM   #5
Senior Member
 
Gary.Jones's Avatar


 
Join Date: Oct 2012
Location: Louisiana
Posts: 6,335
Blog Entries: 1
All goof advice and would be surprised if these steps dont resolve your problem. Good quality electrical tape such as 3M "33" black electrical tape or "35" "colored" electrical tape make an excellent seal that will hold out water and prevent water intrusion for many years. (Try not to touch the sticky side when you apply it) Great stuff.

3M "33" N "35" are the only things I will use and are the industry standards....

Gary
__________________
Gary and Dee, Zowie and Bowie (traveling cat sibs)
2019 Cornerstone 45B, X15-605hp, Imperial, Spartan K3,
2013 Honda CR-V toad, Demco Excali-Bar II,
Demco Baseplate, Demco Toad Light system, 73 de W5Fi
Gary.Jones is online now   Reply With Quote
Old 08-27-2017, 11:20 AM   #6
Senior Member
 
757driver's Avatar


 
Entegra Owners Club
Join Date: Jun 2004
Location: Cambridge, Ontario
Posts: 3,809
Good reminder, thanks. I have to pull that plug apart and check mine.
__________________
Don & Gerri
2014 Entegra Anthem 44B
2014 Honda CRV Touring

1100W Solar, 1200AH LiFePO4 FMCA F443497
757driver is offline   Reply With Quote
Old 08-28-2017, 07:59 PM   #7
Senior Member
 
bamaspiveys's Avatar
 
Join Date: Oct 2016
Location: Murfreesboro, TN
Posts: 338
I replaced that plug back in the winter, it was that corroded. Found the AC evaporator was dripping on it directly, added a hose to redirect the water. Checked it anyway but it is all good.

Just got the EC30 back from Grover, so I went out to put it on and tested it a few times it cranked every time, from the dash and the EC30.

Gremlins.....
__________________
Michael & Wendy
2014 Entegra Aspire 42DEQ
2017 Chevy Tahoe Z71(hers)
2015 Jeep Wrangler Unlimited(his)
bamaspiveys is offline   Reply With Quote
Old 08-28-2017, 08:20 PM   #8
Senior Member
 
brobox's Avatar


 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 21,471
If the command 30 had the old 2.x software anything was possible with that bad program. Hopefully the update took care of the problem.
__________________
Chuck in SW FL
A "Digital" 2019 Cornerstone "B"
A "Classic" 2014 Anthem 42 RBQ---Sold
2016 Colorado Z71 PU
brobox is offline   Reply With Quote
Old 08-28-2017, 08:59 PM   #9
Senior Member
 
Join Date: May 2014
Location: Milford, Michigan
Posts: 918
I had the generator no start issue about 1.5 years ago. when holding the start button on the command 30 all you could hear was the clicking of the fuel pump. It was a bad relay inside the covers. It was still under the Onan warranty at the time and they took care of it when I had it in for a normal service. Tech was familiar with problem and actually had it fixed with a new relay before we drive out of the lot to get breakfast while they worked. K12 relay or something like that was referred to.
__________________

__________________
2013 ANTHEM RBQ
AL and Sally and Ava and Ivy
jestal is offline   Reply With Quote
Reply

Tags
generator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Guardian Generator Starting Issue arboldt RV Systems & Appliances 1 10-03-2016 03:27 PM
Starting or deep cycle and starting battery Crankshaft Class A Motorhome Discussions 7 08-18-2015 07:36 PM
Generator starting issue LSepulveda RV Systems & Appliances 4 03-25-2014 09:42 AM
Starting and Auxillary starting battery hook up NIFFIT MH-General Discussions & Problems 14 03-25-2010 05:06 PM
Southwind 36D Issue after issue after issue.... fixn2gocamp Fleetwood Owner's Forum 4 10-21-2009 08:05 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:30 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×