RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Entegra Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-09-2019, 06:18 PM   #1
Junior Member
 
Join Date: Jul 2019
Posts: 6
Irregular readings on 2017 Anthem Vegatouch

We're having an issue in our 2017 Anthem with faulty readings on our vegatouch. The faulty readings are causing issues with using our appliances / air conditioners / heaters. We're getting messages on our vegatouch indicating we have insufficient power to run certain items while using our generator. Our inverters are also periodically tripping and must be manually reset.

We are getting extremely high readings under the DC Power on our Vegatouch (such as 1359 amps) usually when we are disconnecting from electricity or turning off our generator.

We've contacted both Entegra and Firefly and have had the coach in the shop, but so far there has been no resolution.

Anyone else experiencing similar issues?
__________________

Cjssaws is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-10-2019, 12:10 AM   #2
Member
 
Join Date: May 2017
Location: Ottawa, Ontario, Canada
Posts: 43
We had a very similar issue. It was the communication wire that was badly crimped by firefly in the electric bay behind the electric cord real. Move it around when you are getting the error and you’ll see. Was very hard to find this issue!

I also found that most of my breakers were loose and not fastened properly. But this was not the cause of the issue. Just found it as I was ripping my 2018 cornerstone apart....

Hope this helps you!
__________________

ChuckGirard is offline   Reply With Quote
Old 12-10-2019, 06:28 AM   #3
Junior Member
 
Join Date: Jul 2019
Posts: 6
Response

[QUOTE=ChuckGirard;5069602]We had a very similar issue. It was the communication wire that was badly crimped by firefly in the electric bay behind the electric cord real. Move it around when you are getting the error and you’ll see. Was very hard to find this issue!

I also found that most of my breakers were loose and not fastened properly. But this was not the cause of the issue. Just found it as I was ripping my 2018 cornerstone apart
Thank you Chuck
Cjssaws is offline   Reply With Quote
Old 12-10-2019, 09:31 AM   #4
Senior Member
 
MoHoGo's Avatar
 
Entegra Owners Club
Join Date: Dec 2013
Posts: 1,279
One issue with the early 17's was the mis wiring of the phases in the electrical panels over the drivers seat. It was causing the same issues you are reporting. Yes, this is a long shot as it was an easily identified and corrected issue. Since you have it in the shop this would be easy for them to check.

Please let everyone know what the issue was when corrected.
__________________
Jim & Clatie
2017 Anthem 44A, 2014 Jeep Wrangler Unlimited, Blue Ox Avail, M&G Braking
MoHoGo is offline   Reply With Quote
Old 12-10-2019, 11:03 AM   #5
Junior Member
 
Join Date: Jul 2019
Posts: 6
Thank you for your help fullness. Will check that out
Cjssaws is offline   Reply With Quote
Old 12-10-2019, 04:41 PM   #6
Senior Member
 
dcphil_98's Avatar


 
Entegra Owners Club
Join Date: Jan 2008
Location: Buda (Austin), Texas
Posts: 263
Periodically I would have erratic voltage readings on my Vegatouch. No one including techs at Middlebury could find the problem. NIRVC in Lewisville found the problem. Neither of the main incoming legs had been secured in the breaker box. above driver. Scary...Arching... Shut off power and torqued the set screws. No more Vega problems.
__________________
Dave and Deanne
2007 Travel Supreme Alante (Sold)
2018 Cornerstone 45X, 2019 F-150 loaded with a Cricket SX-3
dcphil_98 is offline   Reply With Quote
Old 12-10-2019, 08:19 PM   #7
Junior Member
 
Join Date: Jul 2019
Posts: 6
Thank you DC Phil. Just wondering what kind of unit you have. I didn't know there were main lugs above driver
Cjssaws is offline   Reply With Quote
Old 12-10-2019, 08:27 PM   #8
Senior Member
 
brobox's Avatar


 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 21,651
Quote:
Originally Posted by Cjssaws View Post
Thank you DC Phil. Just wondering what kind of unit you have. I didn't know there were main lugs above driver
The circuit breaker panels above the drivers seat on the class A Entegras.
__________________
Chuck in SW FL
A "Digital" 2019 Cornerstone "B"
A "Classic" 2014 Anthem 42 RBQ---Sold
2016 Colorado Z71 PU
brobox is offline   Reply With Quote
Old 12-10-2019, 08:32 PM   #9
Junior Member
 
Join Date: Jul 2019
Posts: 6
Okay thank you
__________________

Cjssaws is offline   Reply With Quote
Reply

Tags
anthem



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Irregular Temp Concerns on 2011 Tiffin Phaeton foretom2 Class A Motorhome Discussions 30 08-23-2013 02:50 PM
Irregular Tachometer / Code P0342 / NJ Inspection Bug512 Workhorse and Chevrolet Chassis Motorhome Forum 10 06-28-2013 08:30 AM
Suburban Furnance Irregular Start deandec RV Systems & Appliances 5 12-02-2012 01:18 PM
Monitor Panel readings vs. voltage meter readings larrydp Class C Motorhome Discussions 15 09-26-2012 02:26 PM
Tachometer - irregular movement GLWilliams58 Workhorse and Chevrolet Chassis Motorhome Forum 4 10-11-2007 07:02 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×