Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Entegra Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-06-2016, 03:40 PM   #1
Senior Member
 
Dutch Star David's Avatar


 
Texas Boomers Club
Entegra Owners Club
Join Date: Jun 2009
Posts: 1,843
Water pump won't prime

While at October-fest, I asked one of the technicians how to drain water from the tank without losing prime. I did as he instructed and, of course, lost prime. I've tried the "outside faucet" procedure several times to no avail. Any other tricks? Have you replaced the factory pump with something that will keep and/or re-prime better. I sure hate to think I have to carry a bucket of water in the kitchen sink in order to have water while on the road.
__________________

__________________
2018 Newmar Dutch Star 4369, Spartan K2 Chassis,
Cummins ISL 450HP, Allison 3000

2015 F-150 King Ranch LB 3.5 L twin turbo Ecoboost Toad, Texas Boomers RV Club
FMCA F292298, NRA Benefactor, Newmar KK Lone Stars South
Dutch Star David is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-06-2016, 03:56 PM   #2
Registered User
 
Join Date: Jul 2016
Posts: 299
Quote:
Originally Posted by dlovitt View Post
While at October-fest, I asked one of the technicians how to drain water from the tank without losing prime. I did as he instructed and, of course, lost prime. I've tried the "outside faucet" procedure several times to no avail. Any other tricks? Have you replaced the factory pump with something that will keep and/or re-prime better. I sure hate to think I have to carry a bucket of water in the kitchen sink in order to have water while on the road.
Try priming it like you are winterizing then switch to water tank.
__________________

Misty123 is offline   Reply With Quote
Old 11-06-2016, 04:17 PM   #3
Junior Member
 
Join Date: Aug 2015
Posts: 11
How long did you run the pump? I have run my fresh tank dry and lost prime. I fill the fresh tank full (to put max pressure on outlet) and still have to wait two or three minutes with faucet open for pump to prime. It seems like it takes forever, but it will eventually prime itself.
oldcat is offline   Reply With Quote
Old 11-06-2016, 04:26 PM   #4
Senior Member
 
Dutch Star David's Avatar


 
Texas Boomers Club
Entegra Owners Club
Join Date: Jun 2009
Posts: 1,843
Quote:
Originally Posted by Misty123 View Post
Try priming it like you are winterizing then switch to water tank.
Worked to winterize but still no prime once winterizing hose removed from bucket of water.
__________________
2018 Newmar Dutch Star 4369, Spartan K2 Chassis,
Cummins ISL 450HP, Allison 3000

2015 F-150 King Ranch LB 3.5 L twin turbo Ecoboost Toad, Texas Boomers RV Club
FMCA F292298, NRA Benefactor, Newmar KK Lone Stars South
Dutch Star David is offline   Reply With Quote
Old 11-06-2016, 04:53 PM   #5
Senior Member
 
Join Date: Nov 2015
Posts: 5,233
Pump looses prime when suction line sucks air..........

After that open fresh water tank drain and empty rest of tank

Pump will prime when water level is above end of suction line AND a faucet is open so pump can push air out.
They are designed to run dry w/o damage so if it takes a while to prime no harm
__________________
2007 Dodge 3500 w/Tractor Motor & NUWA 5vr
FT traveling Jan 2007 - Jan 2014
Still DEBT Free
Old-Biscuit is offline   Reply With Quote
Old 11-06-2016, 04:54 PM   #6
Senior Member
 
Dutch Star David's Avatar


 
Texas Boomers Club
Entegra Owners Club
Join Date: Jun 2009
Posts: 1,843
Quote:
Originally Posted by oldcat View Post
How long did you run the pump? I have run my fresh tank dry and lost prime. I fill the fresh tank full (to put max pressure on outlet) and still have to wait two or three minutes with faucet open for pump to prime. It seems like it takes forever, but it will eventually prime itself.
15 minutes. Wonder if we have the same pump? Looks like a bucket in the sink for the rest of this trip. Problem=water pump about 24" above the outlet in the tank??
__________________
2018 Newmar Dutch Star 4369, Spartan K2 Chassis,
Cummins ISL 450HP, Allison 3000

2015 F-150 King Ranch LB 3.5 L twin turbo Ecoboost Toad, Texas Boomers RV Club
FMCA F292298, NRA Benefactor, Newmar KK Lone Stars South
Dutch Star David is offline   Reply With Quote
Old 11-06-2016, 04:57 PM   #7
Senior Member
 
brobox's Avatar


 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 16,907
I lost prime the other day because I forgot to close the tank fill valve. It took 2 gallons through the suction line to get the prime back. I opened the bathroom facet to get the air out. Outside shower would have worked as well.
__________________
Chuck in SW FL
A "Classic" 2014 Anthem 42 RBQ SOLD
A "Digital" 2019 Cornerstone "B" on order
2016 Colorado Z71 PU
brobox is offline   Reply With Quote
Old 11-06-2016, 09:24 PM   #8
Senior Member
 
757driver's Avatar


 
Entegra Owners Club
Join Date: Jun 2004
Location: Cambridge, Ontario
Posts: 2,751
When is the last time the pump worked properly? It may not be the prime.
__________________
Don & Gerri
2014 Entegra Anthem 44B
2014 Honda CRV Touring

1100W Solar, 1200AH LiFePO4 FMCA F443497
757driver is offline   Reply With Quote
Old 11-07-2016, 03:04 AM   #9
Senior Member


 
Join Date: Jan 2016
Location: Spring, TX (Home Sweet Home)
Posts: 1,656
Regarding a replacement, I wired up a separate relay and power circuit driven by the OEM switches powering an Aquajet ARV pump.

The upside is it has a ton of pressure, hasn't ever lost prime, and is a variable speed pump.

The downside is it is very loud. I'm working on a quiet mount for it.

We used the same pump in our last coach to replace the Shurflo 4004 in it. I had such trouble getting reliable service from the 4004 it is relegated to backup status.

-Matt
__________________
2017 Entegra Aspire 44R (bunks) towing 2015 F-150
2012 Tiffin Phaeton 40QKH (Our Phaeton was so nice, we bought it twice)
2016 Open Range RF376FBH (Sold)
Matt D is offline   Reply With Quote
Old 11-07-2016, 05:48 PM   #10
Senior Member
 
Dutch Star David's Avatar


 
Texas Boomers Club
Entegra Owners Club
Join Date: Jun 2009
Posts: 1,843
Quote:
Originally Posted by 757driver View Post
When is the last time the pump worked properly? It may not be the prime.
Right before the tech showed me how to drain the tank. I probably drained less than a quart and it lost prime.
__________________
2018 Newmar Dutch Star 4369, Spartan K2 Chassis,
Cummins ISL 450HP, Allison 3000

2015 F-150 King Ranch LB 3.5 L twin turbo Ecoboost Toad, Texas Boomers RV Club
FMCA F292298, NRA Benefactor, Newmar KK Lone Stars South
Dutch Star David is offline   Reply With Quote
Old 11-07-2016, 08:22 PM   #11
Senior Member
 
757driver's Avatar


 
Entegra Owners Club
Join Date: Jun 2004
Location: Cambridge, Ontario
Posts: 2,751
Quote:
Originally Posted by dlovitt View Post
Right before the tech showed me how to drain the tank. I probably drained less than a quart and it lost prime.
A common problem with these pumps is the inlet valve on the pump gets stuck in the closed position. The pump will run and not pump water. Taking the head off and gently pushing on the valve will free it up.
__________________
Don & Gerri
2014 Entegra Anthem 44B
2014 Honda CRV Touring

1100W Solar, 1200AH LiFePO4 FMCA F443497
757driver is offline   Reply With Quote
Old 11-08-2016, 06:56 AM   #12
Senior Member
 
brobox's Avatar


 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 16,907
Quote:
Originally Posted by 757driver View Post
A common problem with these pumps is the inlet valve on the pump gets stuck in the closed position. The pump will run and not pump water. Taking the head off and gently pushing on the valve will free it up.
Yep, instead of having the problem when the pump is really needed, I am going to elect for an upgraded pump. It's on my list now to change pumps before our next trip and keep the current pump as a backup. My pump is making noise where it never did before, so I don't trust it.
__________________
Chuck in SW FL
A "Classic" 2014 Anthem 42 RBQ SOLD
A "Digital" 2019 Cornerstone "B" on order
2016 Colorado Z71 PU
brobox is offline   Reply With Quote
Old 11-08-2016, 07:11 AM   #13
Registered User
 
Monaco Owners Club
Join Date: Oct 2009
Location: Varies Depending on The Weather
Posts: 8,517
What brand/model of water pump are we all talking about on this thread?

I have an AquaJet -ARV5503 water pump which is self-priming and has never lost prime. I have lost water pressure when the water tank runs low below the water pickup for the pump. Fill the tank and turn on some faucets to release the air and the water supply is all back to normal.

So what's up with these water pumps that are used in the Entegra coaches?

I sure hope that they didn't use ShurFlo water pumps. Never been impressed with their quality and reliability.

Dr4Film ----- Richard
Dr4Film is offline   Reply With Quote
Old 11-08-2016, 07:25 AM   #14
Senior Member


 
Join Date: Jan 2016
Location: Spring, TX (Home Sweet Home)
Posts: 1,656
Richard, our 2012 Tiffin had a Shurflo 4004, I became adept at adjusting and keeping it in working order. Very poor performance.

Imagine my disappointment at discovering the exact same 4004 installed by Entegra in our 2017 Aspire. The first pump didn't survive our first trip, CS sent a new one and shortly after that I modified our coach to use the Aquajet ARV.

I'm currently working on a noise reducing mount and expect that to minimize the significant sound produced by this awesome pump.

-Matt
__________________

__________________
2017 Entegra Aspire 44R (bunks) towing 2015 F-150
2012 Tiffin Phaeton 40QKH (Our Phaeton was so nice, we bought it twice)
2016 Open Range RF376FBH (Sold)
Matt D is offline   Reply With Quote
Reply

Tags
water, water pump



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water pump won't prime and pump.? Rollin Stone Entegra Owner's Forum 26 09-18-2016 02:38 PM
Water pump won't prime Timay 5th Wheel Discussion 11 11-09-2014 10:22 AM
How to prime water pump? bluelghttr National RV Owner's Forum 5 05-13-2014 05:44 PM
Water pump will not prime Rojobro MH-General Discussions & Problems 9 07-10-2012 08:36 PM
rv water pump losing prime kurtwm Class C Motorhome Discussions 2 05-26-2012 06:12 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.