RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Entegra Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-15-2019, 07:26 PM   #1
Senior Member
 
lp5151's Avatar
 
Join Date: Jan 2009
Location: Or-E-gun
Posts: 745
Window Defroster

Today we had a scary situation. We couldn't get the defrosters to work. The only setting that worked was the vent in the dash facing the coach. The windshield was fogging quickly to a point that it looked like a very heavy fog outside. No matter which position I turned the dial, all I got was air from the dash vents, could not get air to the defroster vents. Finally the DW grabbed a towel and wiped the fog off the windshield, and continued to clear the windshield for me until I found a safe place to pull over. Tried to get air to the defroster vents but no luck. Finally for no apparent reason, the air started coming out the defroster vents. Windshield cleared and off we continued. BUT, 10 minutes later the defroster vents quick flowing and the air switched to the dash vents, all while the position dials were set on defrost. Don't understand what was happening...at this point the only vents that air will flow from are the dash vents...all the other setting do not work, no matter the setting, air only comes out of the dash vents. I assume the dash dial is bad and will need replaced? Checked manual, that was a waste...could not understand the "automated" climate controls information. Will call CS in morning to trouble shoot problem.
__________________

lp5151 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-16-2019, 10:25 AM   #2
Senior Member
 
757driver's Avatar


 
Entegra Owners Club
Join Date: Jun 2004
Location: Cambridge, Ontario
Posts: 3,762
Quote:
Originally Posted by lp5151 View Post
Today we had a scary situation. We couldn't get the defrosters to work. The only setting that worked was the vent in the dash facing the coach. The windshield was fogging quickly to a point that it looked like a very heavy fog outside. No matter which position I turned the dial, all I got was air from the dash vents, could not get air to the defroster vents. Finally the DW grabbed a towel and wiped the fog off the windshield, and continued to clear the windshield for me until I found a safe place to pull over. Tried to get air to the defroster vents but no luck. Finally for no apparent reason, the air started coming out the defroster vents. Windshield cleared and off we continued. BUT, 10 minutes later the defroster vents quick flowing and the air switched to the dash vents, all while the position dials were set on defrost. Don't understand what was happening...at this point the only vents that air will flow from are the dash vents...all the other setting do not work, no matter the setting, air only comes out of the dash vents. I assume the dash dial is bad and will need replaced? Checked manual, that was a waste...could not understand the "automated" climate controls information. Will call CS in morning to trouble shoot problem.
You most likely have a vacuum leak or a vacuum hose is collapsing not allowing the system to switch to defrost or floor heat.
__________________

__________________
Don & Gerri
2014 Entegra Anthem 44B
2014 Honda CRV Touring

1100W Solar, 1200AH LiFePO4 FMCA F443497
757driver is offline   Reply With Quote
Old 09-16-2019, 10:46 AM   #3
Senior Member
 
Nowabeachbum's Avatar
 
Entegra Owners Club
Join Date: Apr 2011
Location: Estero, FL
Posts: 1,689
The system is designed to fail in the defrost mode for the very reason you are having. So I would think it might be a stuck vacuum diverter valve. If you need the defrosters before you can get to a repair facility, You might try disconnecting one of the vacuum hoses. It might just force the system into defrost mode, maybe worth a try.
__________________
Gary & Leigh
2019 Entegra Cornerstone 45Y,
2010 Seneca, 2011 & 2014 Anthem, 2017, 2018 Cornerstone(All Sold)
Nowabeachbum is online now   Reply With Quote
Old 09-16-2019, 11:09 AM   #4
Senior Member
 
brobox's Avatar


 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 21,256
I received a TSB on the dash switch on my 19
__________________
Chuck in SW FL
A "Digital" 2019 Cornerstone "B"
A "Classic" 2014 Anthem 42 RBQ---Sold
2016 Colorado Z71 PU
brobox is online now   Reply With Quote
Old 09-16-2019, 03:23 PM   #5
Senior Member
 
Armye7's Avatar
 
Join Date: May 2015
Posts: 223
What did the TSB say??
__________________
Larry & Vickie Carman
2019 Aspire 44W
Springboro Ohio
Armye7 is offline   Reply With Quote
Old 09-17-2019, 07:09 AM   #6
Senior Member
 
brobox's Avatar


 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 21,256
Quote:
Originally Posted by Armye7 View Post
What did the TSB say??
It's up at the MH, but it said there was a recall on the dash switches they hang up and won't switch between A/C and defrost. Call Spartan and ask about it.
__________________

__________________
Chuck in SW FL
A "Digital" 2019 Cornerstone "B"
A "Classic" 2014 Anthem 42 RBQ---Sold
2016 Colorado Z71 PU
brobox is online now   Reply With Quote
Reply

Tags
wind, window



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Defroster Hose Problem - Looking for Help lionel_046 Damon 10 03-19-2008 04:51 PM
TV Cabinet Windshield Defroster Dutch Star Don Monaco Owner's Forum 14 03-16-2008 07:12 PM
Adventurer Defroster Fans Clark Dwinell Winnebago Industries Owner's Forum 6 09-29-2006 06:14 PM
Defroster Heater Fan Problems Sammie Alpine Coach Owner's Forum 2 08-04-2006 03:11 AM
Dash only blows thru the defroster bill jones Winnebago Industries Owner's Forum 3 02-28-2006 11:35 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:03 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×