Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Thor Industries Owner's Forum > Palazzo Motorhomes
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-18-2015, 10:24 PM   #1
Senior Member
 
Daveht's Avatar


 
Thor Owners Club
Texas Boomers Club
Join Date: May 2015
Location: El Paso TX
Posts: 375
Another Question

Hello All

Would someone tell me which battery is for the generator start. All 4 house batteries and the two engine batteries seem to be charged. Is there another one some place?

Generator clicks like dead battery.
__________________

__________________
Dave + Linda
2015 Palazzo 36.1
2010 Honda CR-V toad and Roadmaster Sterling
FMCA F451520 - Texas Boomers - RVM#128
Daveht is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-18-2015, 10:31 PM   #2
EV2
Member
 
EV2's Avatar
 
Join Date: Nov 2014
Posts: 86
Probably would help if you would post the make and model of your coach. But, I highly doubt there is another battery. Gensets normally operate off of the house batteries. I would inspect your connection at both ends for corrosion and secure attachment for starters.
__________________

__________________
EV2 is offline   Reply With Quote
Old 10-18-2015, 10:35 PM   #3
KIX
Senior Member
 
KIX's Avatar


 
Join Date: Dec 2006
Location: St. Augustine, FL
Posts: 3,579
If your gen is a diesel it may be fuel pump. Continue holding the start button and it will start in about 30 or so seconds.
__________________
KIX
'02 Ultimate Advantage 40J Spartan MM - Cummins ISC
2013 Jeep Rubicon JK Unlimited
KIX is offline   Reply With Quote
Old 10-19-2015, 05:58 AM   #4
Senior Member
 
Peterrrr's Avatar
 
Thor Owners Club
Freightliner Owners Club
Join Date: Jun 2010
Location: Ottawa Ont
Posts: 224
The clicking you hear is the generator priming. It sometime takes several cycles for the generator to start. ( For instance, when using the auto gen start it will try 4 times.)

When you manually start it, if it does not start on its own, then while pressing the gen start button also press the aux start button and you will use both coach and chassis batteries to start it. If this does not start it, then you should read the code for the generator from its control panel located under the front hood.

Hope this helps you.
__________________
__________________
Peter,
2018 Thor Four Winds 31Y
Peterrrr is offline   Reply With Quote
Old 10-19-2015, 08:16 AM   #5
Senior Member
 
MisterT's Avatar


 
Join Date: Aug 2014
Location: western NC mountains!
Posts: 2,734
from my experience the Generator uses the COACH 6v batteries to start - I've had several occasions where I let the coach batteries fall below a certain level and the generator would not start on it's on - but if I added the AUX START button along with the GEN SET button, it would start right up... (I am assuming that the Aux Start button provides a connection to the CHASSIS 12v batteries)
if your generator has sat for a while, you can also PRIME it by pressing the GEN SET in the down position for a while, then try it in the UP position to start it.
secondly, you can also try starting the Generator from the generator itself, the same GEN SET button is there as well - prime first, then start.

If none of these seems to work, then you have either a clogged fuel line to the gen set, or, more than likely, you may have less than 1/4 tank of Diesel fuel.
__________________
The Turners 2014 Thor Palazzo DP 33.3 35'

'14 FordFocus, KingTailgater2 DishHD, 200w/10a mobile SOLAR, 75,000+ miles
all continental US states, Alaska, and yes, most of Canada!
MisterT is offline   Reply With Quote
Old 10-19-2015, 06:52 PM   #6
Senior Member
 
Daveht's Avatar


 
Thor Owners Club
Texas Boomers Club
Join Date: May 2015
Location: El Paso TX
Posts: 375
Quote:
Originally Posted by KIX View Post
If your gen is a diesel it may be fuel pump. Continue holding the start button and it will start in about 30 or so seconds.
You were correct! I was not holding the start button long enough.
__________________
Dave + Linda
2015 Palazzo 36.1
2010 Honda CR-V toad and Roadmaster Sterling
FMCA F451520 - Texas Boomers - RVM#128
Daveht is offline   Reply With Quote
Old 11-06-2015, 09:59 AM   #7
Senior Member
 
Join Date: Sep 2014
Location: Early, TX
Posts: 111
The AUX start button is just the opposite from what you've stated. It's primarily for engine start assistance if the chassis batteries go down. The AUX button ties the house batts. into the start circuit. Same result however. Anything connected to either set will benefit from having the output of both tied together
__________________

__________________
Safetysteve5 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Another hitch question gap23 Trailer Towing and Tow Vehicles Discussion 6 08-10-2015 10:22 PM
Battery and Power Question rrthor Alpine Coach Owner's Forum 31 07-12-2015 08:05 AM
Slideout Question -Grumpy- Winnebago Industries Owner's Forum 5 07-01-2015 04:44 PM
A/C & Gas Heater Maint Question Bilgerat Fleetwood Products Owner's Forum 0 03-11-2015 07:46 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.