Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Thor Industries Owner's Forum > Palazzo Motorhomes
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-20-2017, 05:30 PM   #1
Junior Member
 
Join Date: Mar 2017
Posts: 6
Generator won't crank after replacing house batteries

I just bought a 2015 36.2 Palazzo and am having generator issues. The house batteries were bad and after replacing them, the generator appears to have no power (everything else in coach works fine and batteries are fully charged). The indicator light on the generator does not light. The generator worked fine at the dealer so I know it is operational. I hope I am just unfamiliar with the start sequence. Any suggestions?

Thanks,
Ford
__________________

__________________
Fordphares is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-20-2017, 05:57 PM   #2
Senior Member
 
BillSkeen's Avatar


 
Thor Owners Club
Freightliner Owners Club
Join Date: Dec 2011
Location: Austin TX
Posts: 131
How much fuel in the tank. Needs more than a quarter I think.
__________________

__________________
2014 Thor Palazzo 33.3
2009 Chevrolet Silverado toad, Remco Driveshaft Disconnect, Garmin 760LMT GPS
BillSkeen is offline   Reply With Quote
Old 03-20-2017, 06:01 PM   #3
Senior Member
 
Monacoach's Avatar
 
Join Date: Oct 2010
Posts: 1,498
Quote:
Originally Posted by Fordphares View Post
I just bought a 2015 36.2 Palazzo and am having generator issues. The house batteries were bad and after replacing them, the generator appears to have no power (everything else in coach works fine and batteries are fully charged). The indicator light on the generator does not light. The generator worked fine at the dealer so I know it is operational. I hope I am just unfamiliar with the start sequence. Any suggestions?

Thanks,
Ford
Did you try starting it from the switch directly on the genny?
This would eliminate remote switch and or wiring to remote as the problem.
If it wont start from the genny then try connecting the engine batteries by holding down the boost switch. Also check your house battery connections and make sure the cut off is on.
__________________
2008 Holiday Rambler Vacationer 340 Cummins
Monacoach is offline   Reply With Quote
Old 03-20-2017, 06:21 PM   #4
Senior Member
 
Join Date: Jul 2014
Posts: 7,309
You need to look for the generator cable that should be on a house battery post.

It could be laying behind the battery or hooked to a negative post.
__________________
twinboat is online now   Reply With Quote
Old 03-20-2017, 06:40 PM   #5
Senior Member
 
RolandRock's Avatar
 
Rexhall Owners Group
Join Date: Aug 2016
Posts: 135
Sounds to me that someone did not hook up everything correctly when you had the batteries replaced.
__________________
Rock 'N Badger
1996 Rexhall XL2900
Project Beast F53
RolandRock is offline   Reply With Quote
Old 03-20-2017, 06:43 PM   #6
Junior Member
 
Join Date: Mar 2017
Posts: 6
Generator

Fuel tanks are almost full, the switch on the generator has no power either, all of the cables on the house batteries are connected exactly like they were when the generator was operational. It's got me stumped. Thanks for the replies.

Ford
__________________
Fordphares is offline   Reply With Quote
Old 03-20-2017, 07:11 PM   #7
Senior Member
 
Join Date: Jul 2014
Posts: 7,309
If you got any sparks while swapping the batteries, look for a fuse or breaker on the generator cable. It shouldn't be far from the batteries. 150 amp or so.
__________________
twinboat is online now   Reply With Quote
Old 03-20-2017, 07:39 PM   #8
Junior Member
 
Join Date: Mar 2017
Posts: 6
Fixed

That was it Twinboat. Found another post on the same topic and found the fuse. A photo is attached that shows it. The yellow lever needed to be swung up to complete the circuit. There is a red test button hidden behind the cable that trips it. Thanks for the help.

Ford

Quote:
Originally Posted by twinboat View Post
If you got any sparks while swapping the batteries, look for a fuse or breaker on the generator cable. It shouldn't be far from the batteries. 150 amp or so.
Attached Thumbnails
Click image for larger version

Name:	IMG_3732.jpg
Views:	22
Size:	286.8 KB
ID:	155494  
__________________
Fordphares is offline   Reply With Quote
Old 03-21-2017, 10:25 AM   #9
Member
 
Join Date: Apr 2016
Posts: 67
Quote:
Originally Posted by Fordphares View Post
I just bought a 2015 36.2 Palazzo and am having generator issues. The house batteries were bad and after replacing them, the generator appears to have no power (everything else in coach works fine and batteries are fully charged). The indicator light on the generator does not light. The generator worked fine at the dealer so I know it is operational. I hope I am just unfamiliar with the start sequence. Any suggestions?

Thanks,
Ford
Make sure the yellow levers haven't popped out of these breakers
Attached Thumbnails
Click image for larger version

Name:	IMG_6603.jpg
Views:	23
Size:	247.1 KB
ID:	155574  
__________________

__________________
2014 Thor Palazzo 36.1
just_cruisin is offline   Reply With Quote
Reply

Tags
batteries, generator, house batteries



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Crank Up Antenna to Crank Up Dish Bobski12 Technology: Internet, TV, Satellite, Cell Phones, etc. 2 06-19-2016 09:35 PM
Old Crank Sat Out New Automatic In - Crank Replaced With... Nomad Mike MH-General Discussions & Problems 4 11-02-2015 01:11 AM
Generator Won't Start - Engine Won't Crank Rob Howden RV Systems & Appliances 10 08-02-2015 07:35 PM
Is it normal for a generator to stop after starting if the house batteries are weak? PEPPER9950 Class A Motorhome Discussions 5 11-04-2010 12:35 PM
Engine won't crank, batteries charged Rick J Fisher Alpine Coach Owner's Forum 4 10-01-2008 06:44 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:48 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.