Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Thor Industries Owner's Forum > Palazzo Motorhomes
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-11-2017, 05:25 PM   #1
Senior Member
 
BillSkeen's Avatar


 
Thor Owners Club
Freightliner Owners Club
Join Date: Dec 2011
Location: Austin TX
Posts: 195
Water/plumbing issue - Anderson valve?

Noticed rotten egg smell on hot water side so started vinegar cleaning procedure. Got as far as trying to suck vinegar into system with Anderson valve on sanitize/winterize, but no suction. Removed hose and jug of vinegar, connected city water, turned valve to city fixtures, faucets work. Remove city water, move valve to normal, turn pump on, pushing lots of air, spitting some water.

Anyone have any ideas?
__________________

__________________
2014 Thor Palazzo 33.3
2009 Chevrolet Silverado toad, Remco Driveshaft Disconnect, Garmin 760LMT GPS
BillSkeen is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-11-2017, 05:40 PM   #2
Senior Member
 
Berlin Kid's Avatar
 
Thor Owners Club
Join Date: Sep 2012
Location: Columbus, OH
Posts: 541
Turn valve to "Winterize". Pump will pull solution in.
__________________

__________________
Jim & Sandy, Columbus, OH
2014 Thor Palazzo 33.1 Folkstone
FMCA-F434648, TDC, FCOC
Berlin Kid is offline   Reply With Quote
Old 06-11-2017, 05:57 PM   #3
Senior Member
 
BillSkeen's Avatar


 
Thor Owners Club
Freightliner Owners Club
Join Date: Dec 2011
Location: Austin TX
Posts: 195
Quote:
Originally Posted by Berlin Kid View Post
Turn valve to "Winterize". Pump will pull solution in.
Yes, that is where the valve was set when I turned on the pump to suck in the vinegar. Same procedure worked last winter when I winterized, so clueless as to why my pump is sucking air now.
__________________
2014 Thor Palazzo 33.3
2009 Chevrolet Silverado toad, Remco Driveshaft Disconnect, Garmin 760LMT GPS
BillSkeen is offline   Reply With Quote
Old 06-11-2017, 06:18 PM   #4
Senior Member
 
Berlin Kid's Avatar
 
Thor Owners Club
Join Date: Sep 2012
Location: Columbus, OH
Posts: 541
Your original post said "normal".
__________________
Jim & Sandy, Columbus, OH
2014 Thor Palazzo 33.1 Folkstone
FMCA-F434648, TDC, FCOC
Berlin Kid is offline   Reply With Quote
Old 06-11-2017, 06:19 PM   #5
Senior Member
 
Stiltner's Avatar


 
Thor Owners Club
Freightliner Owners Club
Join Date: Sep 2016
Location: Roseville, Ca
Posts: 400
I had the same problem. I had to introduce bleach/water solution through the in line filter canister.
__________________
2016 Thor Palazzo 33.2
14 Honda CRV, Roadmaster Tow Bar, Air Force 1
Stiltner is offline   Reply With Quote
Old 06-11-2017, 06:21 PM   #6
Senior Member
 
BillSkeen's Avatar


 
Thor Owners Club
Freightliner Owners Club
Join Date: Dec 2011
Location: Austin TX
Posts: 195
Quote:
Originally Posted by Stiltner View Post
I had the same problem. I had to introduce bleach/water solution through the in line filter canister.
I was just thinking that as a last resort. Great minds...
__________________
2014 Thor Palazzo 33.3
2009 Chevrolet Silverado toad, Remco Driveshaft Disconnect, Garmin 760LMT GPS
BillSkeen is offline   Reply With Quote
Old 06-11-2017, 06:23 PM   #7
Senior Member
 
BillSkeen's Avatar


 
Thor Owners Club
Freightliner Owners Club
Join Date: Dec 2011
Location: Austin TX
Posts: 195
Quote:
Originally Posted by Berlin Kid View Post
Your original post said "normal".
My original post said "Got as far as trying to suck vinegar into system with Anderson valve on sanitize/winterize, but no suction. "

But I thank you for trying to help. You never know when you think you did something and then end up pounding a slope on your forehead.
__________________
2014 Thor Palazzo 33.3
2009 Chevrolet Silverado toad, Remco Driveshaft Disconnect, Garmin 760LMT GPS
BillSkeen is offline   Reply With Quote
Old 06-12-2017, 07:55 PM   #8
Senior Member
 
jones47172's Avatar
 
Freightliner Owners Club
Join Date: Oct 2013
Location: Floyds Knobs, Indiana
Posts: 488
A facet has to be on, such as the outside shower, or there will be no suction.

Also, I have been fighting a rotten egg smell which goes away after treating with bleach, but only for a period of time. When the smell starts I also notice the water foams when first running water. Talking to The Water Filter Store they said it most likely is a biofilm which cannot be sanitized with bleach. Only the surface of the film is affected leaving the bacteria beneath alive where it can continue to grow.

It was recommended to use Purogene to destroy the biofilm. I have it on order.

3R Purogene Fresh Water Treatment
__________________
Mike & Sue Jones
Venetian A40, formally Palazzo 35.1
Jeep Wrangler Unlimited Sport S
jones47172 is offline   Reply With Quote
Old 06-13-2017, 05:26 AM   #9
Senior Member
 
BillSkeen's Avatar


 
Thor Owners Club
Freightliner Owners Club
Join Date: Dec 2011
Location: Austin TX
Posts: 195
Quote:
Originally Posted by jones47172 View Post
A facet has to be on, such as the outside shower, or there will be no suction....

3R Purogene Fresh Water Treatment
Faucet was on. Have you tried using white vinegar?

Short version on mine - it is working now. I keep playing with it and the tank slowly filled. I tried setting to sanitize again, opened faucet and turned on pump. Viola, sucked the vinegar in.

I did talk to Ron@Anderson several times before and after. Neither of us have a clue what caused the problem. I am going to stop off at Champion Brass in Desoto, TX to pick up a 200RV-RK to repair the valve, just in case.

Thanks all for the responses. Chalking this one up to WHODA. Who Da hell knows!
__________________

__________________
2014 Thor Palazzo 33.3
2009 Chevrolet Silverado toad, Remco Driveshaft Disconnect, Garmin 760LMT GPS
BillSkeen is offline   Reply With Quote
Reply

Tags
plumbing, water



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anderson Valve J Walker Palazzo Motorhomes 54 04-28-2018 10:02 PM
Bounder: Anderson 4 Way Water Valve grumpypapa Fleetwood Products Owner's Forum 2 11-26-2016 03:47 PM
Anderson 200 4 way fill valve MDPD Fleetwood Products Owner's Forum 1 10-24-2016 06:34 PM
Anderson Water Selector Valve info. Don Voyage Palazzo Motorhomes 28 02-07-2016 01:14 AM
Anderson Levelers Issue Texmac1011 iRV2.com General Discussion 3 06-22-2015 05:24 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.