Go Back   iRV2 Forums > CAMPING, TRAVEL and TRIP PLANNING > Navigation, Routes & Roads
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-29-2016, 01:23 PM   #1
Junior Member
 
Join Date: Mar 2016
Posts: 4
Electrical 1999 National Tradewind

Here is my problem, all batteries are good and juiced up but when I turn the key ignition all lights on dash light up and go off like normal. Gauges are all working fine. Go to turn key to start engine I get nothing. I leave key on and then go jump the starter bus starts up. Once bus is started all lights on dash light up and gauges shut down. As I drive the dash lights are lit but go in and out. Also gauges are coming in and out. Ps my electric steps work just fine and when I flick the switch to lock them in place it does not work but will only work when key is on? Never had this problem until the above occurred.
Any suggestions?
__________________

__________________
LennysRV is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-29-2016, 03:54 PM   #2
Senior Member
 
rgvtexan's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Oct 2009
Location: NE WA or S TX
Posts: 2,244
Welcome to iRV2!
My first guess would be the ignition switch itself.
__________________

__________________
04 Horizon QD, 12 Ford Flex, Excalibar, Brakemaster, Winter Texan, RVin! since 1974
Norm, Donna & Tinker Kat 74 MGB-GT, 75 MGB, 01 Z3
Life is a Timed Event, you only get One Go Around!
rgvtexan is offline   Reply With Quote
Old 03-29-2016, 06:21 PM   #3
Junior Member
 
Join Date: Mar 2016
Posts: 4
Thank you but that was not the problem. Any other suggestions?
__________________
LennysRV is offline   Reply With Quote
Old 03-29-2016, 06:45 PM   #4
Senior Member
 
daledrob's Avatar
 
National RV Owners Club
Freightliner Owners Club
Join Date: Sep 2015
Location: Southern Oregon
Posts: 137
An uneducated guess?

Like I said it's not even an educated guess, possibly a poor ground somewhere? I'm not an electrician and I hate electrical problems. So that's the best I can do I hope that it all works out.
__________________
Dale
2000 National Tradewinds 7370 37ft, CAT 3126B 330HP, Allison 3060-6sp Freightliner XC chassis, Ready Brute elite, 2013 Honda CRV
daledrob is offline   Reply With Quote
Old 03-29-2016, 07:12 PM   #5
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,972
Welcome to iRV2.

If your Tradewinds is built on a Freightliner chassis , then the start signal from the ignition switch, does not go directly to the starter, there is a relay involved.
I have had this relay fail twice in five years of owning my Freightliner chassis Newmar coach.
My relay is mounted on a plate , passenger side frame rail behind the wheels, and looks like the picture below ( left hand item) and the pdf file is for the Freightliner P/N along with cross references.
Also if your on a Freightliner the other 2 pdf's could help with your gauge problems.
I've lost track of the relay spec sheet.I'll re-post as soon as I find it.
Attached Thumbnails
Click image for larger version

Name:	Batery fuses.jpg
Views:	26
Size:	153.3 KB
ID:	122650  
Attached Files
File Type: pdf VDC troubleshooting.pdf (130.3 KB, 17 views)
File Type: pdf VDC_Repair FL VDU.pdf (235.5 KB, 13 views)
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 03-29-2016, 07:34 PM   #6
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,972
Ok , I tracked it down and can't add it to my last post.
Attached Files
File Type: pdf MH starter relay.pdf (109.7 KB, 19 views)
__________________

__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Reply

Tags
electrical, national



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New 1999 Tradewind owners needgreaters National RV Owner's Forum 1 03-21-2016 07:51 AM
1999 Tradewind hotwater heater rrowe National RV Owner's Forum 4 02-22-2016 11:45 PM
national tradewind 12v battery disconnect tradeswind National RV Owner's Forum 4 10-08-2014 11:06 AM
Air filter for National Tradewind olcott Class A Motorhome Discussions 5 12-18-2013 10:14 PM
National RV Tradewind LTC katben Class A Motorhome Discussions 7 10-07-2005 02:59 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:13 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.