Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > 5th Wheel Discussion
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 05-11-2014, 09:55 AM   #1
Junior Member
Join Date: May 2014
Posts: 8
2000 Jayco Eagle Fifth wheel - water leaking out of city connection

Hi all,
Hoping for some help here as we are heading out on a trip next Wednesday.
When using the pump and not connected to city/campground water supply, water is flowing out from the city/campground hookup. Is there a valve (that is not working), if so where is it located?. The user manual is less than helpful.

coovara is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-11-2014, 09:58 AM   #2
Senior Member
Join Date: Aug 2002
Location: outside Duluth Mn
Posts: 1,060
There is a check valve that should be close to the city water hook up. It may have some debris in it or it may have failed. Depending on the location of it it may be an easy fix or a real pain.

1996 Dodge CTD auto, #100 fuel plate,advanced timing,upgraded turbo, 2006 Dutchmen 28' 5th wheel with a 12' slide out and 16' boat behind it all
MnTom is offline   Reply With Quote
Old 05-14-2014, 02:22 PM   #3
Senior Member
wingnut60's Avatar
Join Date: Aug 2004
Location: Burleson, TX
Posts: 2,349
Believe all the city hookups have the check valve directly behind the outside connection--very common part, but sometimes very difficult to access. If the hose connection is a round plate with 3 screws,then you could remove the screws and see if there is enough slack to pull the fitting/valve out to get to it. Otherwise, you would get to it from the inside and that can be difficult/tight to reach.
'05 36TK3 Mobile Suites
'10 F450 new to me
'09 F450 Lariat 4x4--died
wingnut60 is offline   Reply With Quote
Old 05-15-2014, 02:31 AM   #4
Junior Member
Join Date: Nov 2013
Posts: 14
A quick temp fix is to buy a brass male garden hose hose plug
kgburns1 is online now   Reply With Quote
Old 05-15-2014, 09:06 AM   #5
Moderator Emeritus
K-Star's Avatar

Newmar Owners Club
Texas Boomers Club
Mid Atlantic Campers
Ford Super Duty Owner
Join Date: Jan 2000
Location: Fulltime - Currently somewhere in the lower 48
Posts: 2,209
mine did that once. I connected a hose from the city water connection to a source (as you would in a CG), turned on the water and it jogged the valve. After that it was fine.
John, Joyce & Libby the Yellow Lab. - Fulltime since `08

2005 Kountry Star FW-35LKSA by Newmar
2012 Ford F-450 Lariat
K-Star is offline   Reply With Quote

jayco, jayco eagle, leak, water, water leak

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Jayco Eagle 33.5RETS vs. Cougar High Country327RES grhtx 5th Wheel Discussion 3 08-23-2014 07:28 AM
New to us, 2000 American Eagle 40VS aw20536 New Rig Show-Off! 36 04-23-2014 06:32 AM
Water Connection Riover Palazzo Motorhomes 4 02-07-2014 09:39 AM
city water inlet not letting water in '96 Southwind bap Fleetwood Products Owner's Forum 8 08-20-2013 09:31 AM
2 questions about my Jayco 253 5th Wheel AndyTblc Jayco Owner's Forum 4 07-27-2013 06:58 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:41 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.