Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > 5th Wheel Discussion
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 06-05-2014, 07:16 PM   #1
Senior Member
Traildust's Avatar

Join Date: Jan 2000
Location: High Desert of Nevada
Posts: 112
Converter Question?

Our Arctic Fox Fifth Wheel came with a Progressive Dynamics 9260 Converter, lately it will not go into boost mode. I have installed a external Charge Wizard Pendant so I can manual input boost mode. When I leave the RV plugged into the house the converter never goes above 13.7vdc. When I select Boost with the remote pendant it works just fine and I see 14.5vdc. I have let the two Trojan T105's discharge down to 12.3vdc and still no boost mode unless I select it? Anyone have an ideas why the converter will not go into boost mode on it's own I am reading all the battery status through my Trace TM500A Battery Monitor.

2013 Arctic Fox 27-5L, B&W Hitch, Reese 5th Airborne , Dual Pane Windows, TriMetric 2025RV. Honda EU2000i, All LED Lighting. Winfield Cross Brace Stabilizer. 2002 F350 7.3 Powerstroke, 6 Speed, 4X4 with lots of upgrades. USN Retired.
Traildust is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-06-2014, 05:04 AM   #2
Senior Member
Shadowcatche's Avatar
iRV2 No Limits Club
Join Date: Nov 2010
Posts: 1,183
Best thing is to call them, (they are responsive) and I Michigan (eastern time zone).

Shadowcatche is offline   Reply With Quote
Old 06-06-2014, 07:04 AM   #3
Senior Member
caissiel's Avatar
Join Date: Oct 2011
Posts: 1,311
Every time I observe my meter on mine I never see anything above 13.6v. I have solar that keeps my batteries to 14.7v every day.
It might be that you manually boost the batteries and the unit only goes in boost momentarily once in a while.
I figure its why my batteries never charged properly with my power plant.
Barbara and Laurent, Hartland Big Country 3500RL. 39 ft long and 15500 GVW.
2005 Ford F250 SD, XL F250 4x4, Long Box, 6.0L Diesel, 6 Speed Stick, Hypertech Max Energy for Fuel mileage of 21 MPusG empty, 12.6 MPusG pulling the BC. ScangaugeII for display..
caissiel is offline   Reply With Quote
Old 06-17-2014, 02:41 PM   #4
Senior Member
go4dsnow's Avatar
Join Date: Jan 2011
Location: Castle Rock
Posts: 229
I think it only goes into boost mode once every 31 days or something. It explains all that pretty well in the book and on their site. Sounds normal to me at first glance.
go4dsnow is offline   Reply With Quote
Old 06-28-2014, 08:20 PM   #5
Senior Member
rfhtlh's Avatar
Join Date: Jan 2007
Location: usa
Posts: 185
I thought I was having problems with my converter so contacted progressive. they told me to turn off the converter, access the converter and disconnect the batteries. put a voltmeter on the output terminals of the converter and turn it on. the meter should read 14.2 than drop to 13.7 than to 13.2. if it does, the inverter is working correctly.
rfhtlh is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 Fleetwood Wilderness power converter issues deanpence 5th Wheel Discussion 6 05-23-2014 02:35 PM
05 Itasca Meridian DP DC to AC converter Question fputnam RV Systems & Appliances 5 03-27-2014 10:46 AM
Converter question airbrushguy Going Green 8 02-03-2014 06:51 AM
Progressive Converter install question SeeTheUSA RV Systems & Appliances 10 01-13-2014 10:09 AM
120VAC to 12VDC converter issues Karlos National RV Owner's Forum 5 06-07-2013 06:52 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:16 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.