Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > 5th Wheel Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-22-2013, 07:13 AM   #1
Junior Member
 
Join Date: Jun 2011
Posts: 9
furnace blues

hello every-one I have a 1996 Salem 29ft. every so often when you turn it on it wont light just blow cold air. An than the next time you turn it on it will be just fine. is there a thomo-coupler on this furnace or does it light by 12 volts? Thanks in advance for any help.
__________________

__________________
spotknot is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-22-2013, 08:42 AM   #2
Registered User
 
Join Date: Dec 2012
Posts: 50
It lights via 12v, so your batteries cannot be low.

Possible causes:
low gas pressure
intake or exhaust vents obstructed
dirty burner
electrode(s) out of adjustment, dirty, or defective
bad control board

Part of low gas pressure can be a build-up of oil in the gas regulator. I recently had similar problems. I removed the regulator and dumped almost 2 ounces of oil out it. That fixed all LP flow and ignition problems.
__________________

__________________
Route 666 is offline   Reply With Quote
Old 01-24-2013, 06:28 AM   #3
Junior Member
 
Join Date: Jun 2011
Posts: 9
thanks for the help will check your list as soon as it warms up a little its -25cel. here this morning.....
__________________
spotknot is offline   Reply With Quote
Old 01-24-2013, 06:50 AM   #4
Senior Member
 
winniman's Avatar
 
Join Date: Jan 2013
Posts: 628
had the same problem and it was the thermostat. try wiggling the thermostat or move it slightly left or right on the switch. hope it helps.
__________________
winniman is offline   Reply With Quote
Old 01-24-2013, 07:33 AM   #5
Senior Member
 
Rick Long's Avatar
 
Fleetwood Owners Club
Solo Rvers Club
Join Date: Dec 2007
Location: Some Place
Posts: 1,161
Send a message via Yahoo to Rick Long
Check the sail switch... it's a micro switch that will be next to the cabin blower wheel. It's function is to make sure the fan is blowing before it lights the burner. If the switch is stuck or defective the fan will start but the igniter will never know... result, cold air only.
__________________
1999 Fleetwood Bounder 32H
Many Places Full Time
No Dog * No Cat * No Co-Pilot
Rick Long is offline   Reply With Quote
Old 01-24-2013, 08:38 AM   #6
Senior Member
 
winniman's Avatar
 
Join Date: Jan 2013
Posts: 628
just to expand on my comment a bit. mine was doing the same thing. sometimes it would work, then next time it wouldnt. got frustrated and shut off the thermostat (so i thought), and as i was walking away i heard the furnace light. went back in and checked the heat/gas /elect. slide switch on the therm. it was off centre of where it said gas. i guess my thermostat is half worn out but now find if i put the slide switch in that same position it works every time. at some point i will replace the thermostat but now that i have it figured out it is not as urgent. hope this helps. my unit is a 2000
__________________

__________________
winniman is offline   Reply With Quote
Reply

Tags
furnace



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.