Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > 5th Wheel Discussion
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 11-01-2011, 08:10 PM   #1
Junior Member
Join Date: Nov 2011
Posts: 8
Newbe having electrical problems

I have a 2000 Travel Supreme 34 RL TSO. I am plugged in to my garage on 110 and using a adapter to plug in to my 50 amp cord. I installed a 50 amp plug in the garage and as soon as i plug the cord in the converter/charger fuse blows and everything shuts off.

Eugene69 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-01-2011, 08:15 PM   #2
Senior Member
450Donn's Avatar
Join Date: Jun 2006
Location: Dallas,OR
Posts: 2,237
Mis wired in the garage. Bad adapter.

Don and Lorri
2007 Dodge 3500 dually
Resident Dummy.
450Donn is offline   Reply With Quote
Old 11-01-2011, 08:34 PM   #3
Community Moderator
"007"'s Avatar

Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 24,488
Its a good thing you blew the fuses and not all your electronics in coach.
Before you go any further take a look at these links.


Make sure service is installed correctly.

Welcome to irv2
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
"007" is online now   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical problems, 1988 national RV Dolphin. wardoe2000 National RV Owner's Forum 6 06-29-2011 09:05 PM
Electrical Problems painter3066 Workhorse and Chevrolet Chassis Motorhome Forum 6 06-16-2011 10:57 AM
110 electrical problems. womps Monaco Owner's Forum 4 01-18-2011 05:48 PM
Electrical Problems friendship14 Gulf Stream Owner's Forum 3 07-26-2008 06:28 PM
more electrical problems Buddy and Beverly Alpine Coach Owner's Forum 8 06-10-2007 11:18 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:58 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.