Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > Trailer Towing and Tow Vehicles Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-25-2013, 03:36 PM   #1
Senior Member
 
VanDiemen23's Avatar
 
Join Date: Oct 2010
Posts: 778
P0128 code set

GMC 8100 sets the code for low engine temp frequently. Lots of discussion on various forums, but no consensus. could be T-stat, could be a connector to the coolant temp sensor, etc, etc, etc.

Was wondering if anybody else with this engine had this problem and what the solution was.
__________________

__________________
VanDiemen23 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-25-2013, 03:43 PM   #2
Senior Member
 
lx22's Avatar
 
Join Date: Feb 2013
Posts: 162
Replace your thermostat and coolant sensor and reset computer and you will fix the problem.
__________________

__________________
07 jayco 314 bhds
Friendswood, tx
lx22 is offline   Reply With Quote
Old 02-25-2013, 05:40 PM   #3
Senior Member
 
VanDiemen23's Avatar
 
Join Date: Oct 2010
Posts: 778
well, I was hoping to avoid the shotgun approach. Seems every GM vehicle out there has a forum discussing this issue, so it's likely to be a single common issue.
__________________
VanDiemen23 is offline   Reply With Quote
Old 02-25-2013, 06:42 PM   #4
Senior Member
 
lx22's Avatar
 
Join Date: Feb 2013
Posts: 162
Quote:
Originally Posted by VanDiemen23 View Post
well, I was hoping to avoid the shotgun approach. Seems every GM vehicle out there has a forum discussing this issue, so it's likely to be a single common issue.
Actually not a shotgun approach. I am a certified tech and i see this code on many gm vehicles and i have found if you replace just the thermostat 70 percent of them will set the code again! So take my word and replace both and go camping!!!
__________________
07 jayco 314 bhds
Friendswood, tx
lx22 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.