Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > Trailer Towing and Tow Vehicles Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-02-2012, 09:01 PM   #1
Senior Member
 
slabman's Avatar
 
Join Date: Oct 2002
Location: Plano TX
Posts: 2,217
US Gear Power Module

I've been using a US Gear brake for several years now and recently I've had 3 power modules go bad in the past year. The last one I replaced in May and now I find it, too, is bad. Has anyone else had this issue and what is the solution? A call to the mfr. last time was no help and cost me a couple hundred for the new module which has now gone bad.
__________________

__________________
Slabman
2014 Newmar Essex 4544
2007 Lexus LX470 Toad
slabman is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-02-2012, 09:12 PM   #2
Junior Member
 
Join Date: Sep 2008
Posts: 13
I thought I had a bad module about 1 year ago and found this add. I called and bought a PM-6002 which was what I was using and paid $99 and they did not want my old one back.
Optional Power Module with Feedback Alarm Feature (PM-6002)

Bob
__________________

__________________
Bob & MaryAnn Lancaster,Pa
2005 Itasca Sunova 29R P-32
MA&BOB is offline   Reply With Quote
Old 12-02-2012, 09:29 PM   #3
Senior Member
 
slabman's Avatar
 
Join Date: Oct 2002
Location: Plano TX
Posts: 2,217
Yeah, I did get a replacement for the same $, but now TWO of these #6002 have gone bad, so am becoming very disappointed with the product. I love the brake, but it has to also keep working or it's not much good.
__________________
Slabman
2014 Newmar Essex 4544
2007 Lexus LX470 Toad
slabman is offline   Reply With Quote
Old 12-03-2012, 10:04 AM   #4
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 22,799
If you had three in a row go bad on the same vehicle I'd suspect another issue.. Possibly a bad electrical connection "Up-Line" from the power unit.. or even a bad battery in the towed.

She does suck the amps when she brakes.

Another possible cause is the TC-6000 in the motor home, (And likewise the wires supporting it) it may be activating the power unit when it should not.

Another suspect is the control unit under the dash in the towed.. it too may be sending power to the power unit when it should not.

True story, much shortened.. A neighbor in one RV park came to me for help, strong wind and his power awning would not retract. I had to go to the method of last resort to roll it up for him and called Rachel the RV GIRL (That's her license plate).

She came out and diagnosed a bad motor, replaced it (Under warranty) then had to replace the replacement,, This time they also replaced the controller and the switch as the switch was sticking and the controller was not sensing the motor stall and cutting power as the Attwood (A&E Weatherpro) controllers are supposed to.

Your system may also have failure of either the master controller in the motor home or of the slave in the towed sending power to the solenoid and burning it out.
__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 12-03-2012, 10:18 AM   #5
Senior Member
 
slabman's Avatar
 
Join Date: Oct 2002
Location: Plano TX
Posts: 2,217
Thanks. I spoke with Lee at USGear and he's sending another replacement. He did confess it IS the most replaced component, but not a problematic part.

Also, the is an install in a different toad...same model as the old one.
__________________
Slabman
2014 Newmar Essex 4544
2007 Lexus LX470 Toad
slabman is offline   Reply With Quote
Reply

Tags
power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.