Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > Toy Haulers Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-05-2012, 09:06 AM   #15
Junior Member
 
Invstr55's Avatar
 
Join Date: Jul 2012
Posts: 14
It sounds like you have a repair facility problem, their letting your TH sit and not repair it. I have found Dutchman to be very responsive in getting things corrected but the repair facilities seem to always be too busy to actually fix things, they are so busy with angry customers and making excuses for not having it finished that they have no time for warranty repairs that pay less than retail repairs. I am sorry to hear you are stuck in this situation, I have been forced to do many of the fixes on my voltage because of this but the good news is that Dutchman has supplied the parts and knowledge to allow me to do these. This is more a problem of the dealers treating the service departments as just a profit center rather than a part of their responsibility to the manufacturer to service their warranty that they are all too willing to talk about when you are buying. Call Dutchman directly if you have not already done that, you may be surprised with how concerned they are that you get to use your TH.
__________________

__________________
Invstr55 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-05-2012, 12:23 PM   #16
Junior Member
 
Join Date: Dec 2011
Posts: 5
I concur

Quote:
Originally Posted by Invstr55 View Post
It sounds like you have a repair facility problem, their letting your TH sit and not repair it. I have found Dutchman to be very responsive in getting things corrected but the repair facilities seem to always be too busy to actually fix things, they are so busy with angry customers and making excuses for not having it finished that they have no time for warranty repairs that pay less than retail repairs. I am sorry to hear you are stuck in this situation, I have been forced to do many of the fixes on my voltage because of this but the good news is that Dutchman has supplied the parts and knowledge to allow me to do these. This is more a problem of the dealers treating the service departments as just a profit center rather than a part of their responsibility to the manufacturer to service their warranty that they are all too willing to talk about when you are buying. Call Dutchman directly if you have not already done that, you may be surprised with how concerned they are that you get to use your TH.
We had many issues on our Voltage 3200, too many to list, but they included the slides, slide motor, and numerous water leaks. We went to the local dealer multiple times and they worked with Dutchman and Lippert directly for all the technical issues and repaired everthing resulting from poor workmanship. One thing the dealer told me when bringing it in a second and third time for the same water leaks was that Dutchman did not pay for warranty work on the same item twice. It was on the local dealer to get it fixed and they treated me well as they tried to find and fix the leaks in the slides. The other problems have been minor and I also just fix them myself.
__________________

__________________
Randot is offline   Reply With Quote
Old 10-08-2012, 06:58 AM   #17
Member
 
Join Date: Dec 2010
Posts: 42
We took delivery of out 3950 last week. I was amazed that on the shakedown trip I only found 4 or 5 minor problems that I fixed myself! We love the unit and couldn't be more pleased for now. Maybe in six months it will be another story but so far so good. Back in 2006 I paid over $350,000 for a new Monaco Dynasty Class A and it was a nightmare from day one. Nothing but problems and they were big ones I could not fix. I ended up selling the coach within one year. I think the comment here about the service facilities is spot on. Some dealers are so overwhelmed they just let your coach sit for a week or two before anyone even looks at it! Try fixing as much as you can by yourself and have Dutchmen send you the parts.
__________________
hitman007 is offline   Reply With Quote
Old 10-09-2012, 06:13 PM   #18
Junior Member
 
TheNewFarmer's Avatar
 
Join Date: Sep 2012
Location: Lafayette Indiana
Posts: 10
I e-mailed the dealer today and the parts still aren't here..I e-mailed Dutchman and sent them my vin # and the story of it being in the shop so many times and how long. We will see what happens. As far as the problems and them sending me the parts to install isn't going to happen. I am not able to install the awning, kitchen floor (galley slide ate a hole in it), trim around outside between the fiberglass and metal skirting, tape the covers seams on the wood grain paneling and this list goes on and on.. I probably could replace the the gas station pump if they would send to me. The things they have fixed is both DVD players had to be replaced, the center channel speaker wiring was shorted, the trim around both big slides had to be replaced, ruined by a water leak from back bathroom and under kitchen sink that soaked up in the carpet and wicked it's way into the wood so the wood swelled, this happened the first time camping. They replaced one of the light lenses because it fell out and broke. It fell out again when I brought it home but if stayed on top of the galley slide (didn't break) but it took a couple trys to fiqure out why the slide wouldn't extend all the way!! At least the dealer sent someone up to my house to fiqure that out!! Thanks for letting me rant!!
__________________

__________________
TheNewFarmer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Generator/Shore power - voltage indicator question jbobst National RV Owner's Forum 11 10-21-2010 11:44 AM
Onan low voltage UltraKen RV Systems & Appliances 8 07-10-2010 04:33 AM
RVUpgrades -- New! Surge Guard 30 & 50 AMP Voltage Regulators DriVer Vendor Spotlight (Deals, Announcements & More) 9 05-02-2010 05:19 PM
Battery voltage question NavlAv8r Class A Motorhome Discussions 14 05-13-2009 10:53 AM
Frank's Super Voltage Booster Model FA 30 Pubtym Technology: Internet, TV, Satellite, Cell Phones, etc. 14 04-27-2009 08:12 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:46 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.