Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > Toy Haulers Discussion
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 04-12-2016, 08:43 AM   #1
Join Date: Oct 2011
Posts: 41
Basement vacuum fixed:))

Finally after almost 4 years, decided to "fix" vacuum. Removed switch to discover Heartland had put a screw thru the flexible hose at the point it would NOT allow my hose to make contact to the 2 electrical pins to activate the motor. What a simple fix!!! My fault because I did NOT do a thorough PDI...OR...no quality control at the factory. Oh, well, love knowing HOW to fix most of my RV probs. Life is GRAND
IOWASTROKER is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hydro Hot basement heat ?? no fan at heater vent in basement wernie1 Travel Supreme Owner's Forum 3 01-01-2016 11:55 PM
Fixed, loud surround sound volume after LCD installation Indyrvfolks Technology: Internet, TV, Satellite, Cell Phones, etc. 15 11-28-2008 03:43 PM
Basement AC finally fixed!!! Lucchese1 Winnebago Industries Owner's Forum 27 07-01-2008 12:42 PM
W22 Tail Lights Fixed - DriVer An Enormous Help! - Flashers Fixed Update 9/5/07 GerryB54 Workhorse and Chevrolet Chassis Motorhome Forum 30 09-05-2007 01:42 PM
Fixed, loud surround sound volume after LCD installation Winnebago Industries Owner's Forum 15 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:48 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.