Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > Toy Haulers Discussion
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 06-22-2010, 04:27 PM   #1
Junior Member
Join Date: Jun 2010
Posts: 1
Ragen FS2500 electrical issues

Hello, new member here! Have a Ragen, 2007, FS2500. It's been a great trailer overall. However, I have always suspected electrical issues from day 1. the biggest problem is that it eats batteries. Camping World replaced the converter last year, and told me all my problems were solved..... NOT. It just ate another battery (Interstate). So I replaced with another battery (used but good, from my boat), charged it, and went camping. It lasted about 4 hours with everything running. I hooked up to shore power and everything was fine. When we started packing up, the beds would not raise. After checking all the fuses, and breakers I could not find anything bad, but I did notice that all the outdoor lights were also not working. RV shop jumped the pull switch up front and everything works. I am hoping that I finally have an obvious sign of what is really going on. Anybody had any similar issues?


Woodro is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-31-2013, 06:24 PM   #2
Junior Member
4x4eclipse's Avatar
Join Date: Dec 2013
Posts: 8
I just got rid of my Ragen 3605 Blackhawk 5th wheel. It was an awesome rig. Had no issues with electrical. Every once in a while I had to re tighten the screws in the fuse box but other than that no issues. I always have two batteries connected. The trailer was Tom much weight with three axles. I'm glad we downsized.

4x4eclipse is offline   Reply With Quote
Old 12-31-2013, 08:25 PM   #3
Senior Member
Join Date: Sep 2012
Posts: 4,232
What converter did they put on?
Are your batteries filled with water?
What's a "pull" switch up front?
jesilvas is offline   Reply With Quote
Old 01-01-2014, 03:50 AM   #4
Senior Member
94-Newmar's Avatar
Join Date: Nov 2009
Posts: 2,043
You say battery, not batteries. Singular? A single battery is all you have? If so I'm surprised it lasted 4 hrs with nominal usage. You say the "pull switch" - I'm assuming you mean the battery disconnect push/pull lever? If they jumped around it and things began working then the switch is bad. If it was bad and or disconnected then the converter wouldn't be able to re-charge the battery - so when you unplugged from shore you no longer were being powered by the Converter, thus everything went dark. I guess I'm not understanding exactly what you're asking/saying/trying to convey?
94-Newmar Kountry Star 40-KSDP
Spartan/Cummins 8.3C-300HP/Allison 3060 WTEC-II/25yr RV Tech RVIA Certified/Onan-Cummins Certified
94-Newmar is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bounder: Battery Control Box Electrical Issues Hemi350 Fleetwood Products Owner's Forum 7 10-12-2016 11:28 AM
Phantom Electrical issues Old Rv'er Alpine Coach Owner's Forum 14 12-02-2009 10:51 PM
Cummings NW in Portland, OR & Electrical Issues Old Rv'er Alpine Coach Owner's Forum 3 08-30-2008 09:13 AM
In-Motion satelite system -electrical issues campernut2 MH-General Discussions & Problems 10 04-17-2007 02:16 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:06 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.