Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > Travel Trailer Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-19-2014, 11:38 PM   #1
Senior Member
 
TravisNuwa81's Avatar
 
Join Date: Jan 2013
Posts: 478
Electric ignition hot water heater wont light

My electric hot water igniter wont allow gas to come into the chamber. The igniter wont click and no gas is present. I have no idea what to do. Can I get rid of the electric ignite and install the old fashioned manual lighter
__________________

__________________
TravisNuwa81 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-20-2014, 12:53 AM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,970
Do you have an owners manual for the water heater and a voltmeter ?
Any other 12volt systems not operating?
Can you post the brand and model number of the heater ?
I'm pretty sure you can't go back to a manual control heater without replacing the whole tank.
__________________

__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 07-20-2014, 01:47 PM   #3
Senior Member
 
Join Date: Sep 2012
Posts: 4,232
Don't degrade and get a pilot model.

There are simple things to check with a volt meter. You need model number and some knowledge to trouble shoot, they are easy.
__________________
jesilvas is offline   Reply With Quote
Old 07-20-2014, 04:15 PM   #4
Senior Member
 
Join Date: Jun 2012
Location: Jacksonville, Florida
Posts: 581
Make sure you have 12v working to get the igniter to work. Should be able to hear clicking of electrode.

When you get air into the lines (like when you refill tanks) it can be a pain to get LP back into them. I usually start at the stove's front burner and use a grill igniter to hold a flame to the burner while holding in the knob to the ignite position till it lights and stays lit. Once that is done, I then go to the water heater and flip on that switch. I can hear the electric igniter clicking. If it stops and I do not hear the burner (may have to have someone outside by it) I flip the switch off and on again. Need to purge the air out and it may take 3 times AFTER purging the stove and the main LP line on the RV. Otherwise, you are fighting a long battle to purge with only the water heater.

Oven and furnace take time to purge also. After doing the stove, I use the grill igniter in the oven to light the pilot there too.
__________________
Bob and sometimes - Nina - a Staffordshire Terrier/a SPOILED pit and her kitty Spaz
2006 Dodge SLT 2500 4x4 Cummins Quad Cab w/AT and 3.73
2007 Salem Sport LE 26FBSRV (TH) w/ my Victory Motorcycle in it or a EZ GO Shuttle cart.
NFlcamper is online now   Reply With Quote
Old 07-20-2014, 04:33 PM   #5
Senior Member
 
homeless's Avatar
 
Join Date: Mar 2012
Location: http://binged.it/1KdDqKO
Posts: 2,313
Blog Entries: 1
When I first got my motor home going and wanted to get some gas on a rainy day I pulled into a HI V station and was gassing up under there awning. As you can guess I got board waiting for my pump to get done so I was thinking how the hot water heater has not come on yet. As I opened the door to the water heater I notice there was a little fuse. I garbed it to see if I could tell if it was blown. As I wiggled it, it came to life " Walla " Flames shoot down the tube and the hot water heater was working. As I suddenly realized where I was with flame shooting up into the bowels of the heater. I was about to have a movement myself.. I went in and turned off the heater. Problem was solved and I learned not to mess with fire at the gas station.....
homeless is offline   Reply With Quote
Old 07-20-2014, 04:53 PM   #6
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,216
You might have to reset the electronic board if it's had repeated failures to ignite. Check in your manual to find out how. If you don't have a manual, Google manufacturer and model to find one on line.

Also, it could be that hot water doesn't need heating. It's a water heater, not a HOT water heater.
__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote
Old 07-20-2014, 06:26 PM   #7
Senior Member
 
TravisNuwa81's Avatar
 
Join Date: Jan 2013
Posts: 478
Suburban Sw6d is the water heater. I dont have a volt meter to check. Ive used a test light and im not showing power to the switch. I was told that the gas solenoid needs to know of theres gas present but my regulator doesnt have any wires coming out of it. Im so novice to this stuff...
__________________
TravisNuwa81 is offline   Reply With Quote
Old 07-20-2014, 07:19 PM   #8
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,216
Multimeters are free often at Harbor Freight, less than $20 at most hardware stores. It's cheaper than a service call and can be used for many things. A link to the manual is here:

http://dutchmen.com/image/data/docum...per_Manual.pdf

It does have to be shut off for 5 seconds after 3 tries. Have someone in RV turn on while you wait at the WH to listen for valve to come on and click of ignition.
__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote
Old 07-20-2014, 08:13 PM   #9
Senior Member
 
Join Date: Sep 2012
Posts: 4,232
Ok, test light works too.

When you say switch; which switch? The one to turn on the gas side of the WH? If there's no power coming to it at all, there's the first problem to trace down. Are you sure you have good ground on the test light?

The gas valve does NOT know if gas is present or not.
__________________
jesilvas is offline   Reply With Quote
Old 07-20-2014, 08:26 PM   #10
Senior Member
 
TravisNuwa81's Avatar
 
Join Date: Jan 2013
Posts: 478
Quote:
Originally Posted by jesilvas View Post
Ok, test light works too.

When you say switch; which switch? The one to turn on the gas side of the WH? If there's no power coming to it at all, there's the first problem to trace down. Are you sure you have good ground on the test light?

The gas valve does NOT know if gas is present or not.
Theres only one switch. Then beside that is a red reset light. It hasnt turned on. Is there a way I can bypass all of the factory wiring and test it? I could care less about how it looka if it works.
__________________
TravisNuwa81 is offline   Reply With Quote
Old 07-20-2014, 08:29 PM   #11
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,216
Quote:
Originally Posted by TravisNuwa81 View Post
Theres only one switch. Then beside that is a red reset light. It hasnt turned on. Is there a way I can bypass all of the factory wiring and test it? I could care less about how it looka if it works.
You could use jumper wires from a good 12v source to the 12 v (+) wire in the water heater compartment. Ground should be O.K.
__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote
Old 07-20-2014, 08:50 PM   #12
Senior Member
 
kayakcrazy's Avatar
 
Outdoors RV Owners Club
Join Date: Mar 2013
Location: Regina, Saskatchewan
Posts: 303
Here's a place to start - Atwood Water Heater Troubleshooting

On my Atwood I have two switches that need to be on. Please supply a brand and model number, was it working or not. Good luck in your search. Let us know how you are getting along with this.
__________________
"We were not placed on this earth to see through one another, but rather to see one another through!"
2013 Timber Ridge 260RLS, 2013 GMC Sierra 6.2L
kayakcrazy is offline   Reply With Quote
Old 07-20-2014, 09:35 PM   #13
Senior Member
 
Join Date: Sep 2012
Posts: 4,232
All the water heater needs is a 12V power source to the board. After that, it takes over.
I think you just need to find why you lost 12V power.
__________________
jesilvas is offline   Reply With Quote
Old 07-20-2014, 09:37 PM   #14
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,216
Quote:
Originally Posted by jesilvas View Post
All the water heater needs is a 12V power source to the board. After that, it takes over.
I think you just need to find why you lost 12V power.
I agree. Could be a bad fuse or bad switch.
__________________

__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote
Reply

Tags
heater, water, water heater



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help on hot water heater stan5711 Monaco Owner's Forum 40 05-09-2014 08:27 AM
Pex tubing into hot water heater leak kjackson Class A Motorhome Discussions 12 04-29-2014 01:10 AM
Water heater issue 1985 Allegro dtschacher Tiffin Motorhomes Owners Forum 2 01-18-2014 10:59 PM
Help! Hot water heater isn't starting? Statgeek RV Systems & Appliances 19 08-11-2013 09:19 AM
Atwood Water Heater won't re light jcwhitty RV Systems & Appliances 7 08-04-2013 10:52 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:16 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.