Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > Travel Trailer Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-18-2015, 01:01 AM   #1
Senior Member
 
Join Date: Dec 2012
Location: Paradise, Ca.
Posts: 409
Fantastic Fan Question

Today I went in our trailer and heard a noise coming from the living room fantastic fan, hard to describe other then it sounded like the electric motor was trying to start the fan or laboring to open the vent cover. The battery disconnect was switched to "off", the vent switch was "down", the vent cover was closed and the fan speed was at "1". I turned the fan speed to "0" and the noise stopped. I have been in the trailer numerous times and the fan was not making any noise before today. A while back the bedroom fan made the same noise, the fan speed was on "1", I turned it to "0" and the noise stopped, the battery switch was "on" and the trailer was on shore power.

Anyone else have this issue?
__________________

__________________
2017 Cardinal 3250 5th wheel
2016 Ram 3500 Crew Cab long bed with Aisin Transmission
1010 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-18-2015, 01:15 AM   #2
Senior Member
 
Mr_D's Avatar
 
Solo Rvers Club
iRV2 No Limits Club
Join Date: May 2011
Location: Vancouver, WA
Posts: 28,423
Never heard of it.
__________________

__________________
2009 45' Magna 630 w/Cummins ISX 650 HP/1950 Lbs Ft
Charter Good Sam Lifetime Member, FMCA, SKP
RV'ing since 1957, NRA Benefactor Life, towing '14 CR-V
Mr_D is online now   Reply With Quote
Old 07-18-2015, 05:23 AM   #3
Senior Member
 
tuffr2's Avatar
 
Join Date: Sep 2012
Location: Palm Coast Florida
Posts: 2,454
I always turn mine to 0. If not set to 0 I think some kind of sensor is on. Mine makes a slight hum. Remember there is some sort of rain sensor.

Ok...call me stupid because I believe these fancy fans can be set to work automatically but I just use mine the old fashion way. I turn it on and off manually.
__________________
tuffr2 is offline   Reply With Quote
Old 07-18-2015, 06:20 AM   #4
Registered User
 
Gulf Streamers Club
Join Date: Jun 2010
Location: Trois-Rivieres, QC, Canada
Posts: 414
Send a message via Skype™ to normandlegra
Your fan was picking up some 12 VOLTS and was trying to operate normally but being only at level 1, it was only using 1/3 or 1/4 of the voltage, not enough juice to open the vent cover and to get the fan working properly; I always close my automatic Fantastic fan just in case it rains and that the fan does not close the cover.
__________________
normandlegra is offline   Reply With Quote
Old 07-18-2015, 06:51 AM   #5
IC2
Senior Member
 
IC2's Avatar


 
Join Date: Jun 2010
Location: Upstate New York
Posts: 1,877
I had a similar experience - called the manufacturer and a new one was on my doorstep in two days. Yes, it was 'officially' well out of warranty by 4-5 years but they stood up and did the good customer service response. I believe that Camco now owns them so don't know if they're still as well tuned in to the occasional woes of their product. Our new trailer has another brand and while the two that are in it are OK, they just aren't as capable as a Fantastic product.
__________________
Dave W along with my DW, Susan and our poodlepups, Callie & Molly,2011 Ford F250 6.7 CCLB, 5er Hitch Option w/B&W Hitch,,Ride Rite air bags, 2014 Montana High Country 343RL (38')
IC2 is offline   Reply With Quote
Old 07-18-2015, 07:40 PM   #6
Senior Member
 
Join Date: Dec 2012
Location: Paradise, Ca.
Posts: 409
Thank you all for your help.
Tuffr2, there are no rain sensors on the fans, like you & I agree so I was doing it manually and it was on "0", but since the wife takes care of the inside, I opted to go with the electric (has to be on "1" to work) to save me another thing to do.
Normandlegra, I think you are right, I discovered the battery disconnect switch is overrided by the solar battery trickle charge when that switch is on, not much power, but it is enough to light up the radio and turn on the LED lights.
IC2, thanks, I will keep it in mind if the problem continues.
__________________
2017 Cardinal 3250 5th wheel
2016 Ram 3500 Crew Cab long bed with Aisin Transmission
1010 is offline   Reply With Quote
Old 07-19-2015, 06:06 AM   #7
Senior Member
 
rideandslide's Avatar


 
Join Date: Sep 2013
Location: Waynesville Georgia
Posts: 1,272
I know tere are several different models, as far as options you get on the fan. Our new camper has one ( i'm sure the basic model ) and i had never herd of them. True to their name, it is Fantastic !!!!
__________________
rideandslide is offline   Reply With Quote
Old 07-19-2015, 07:14 AM   #8
Registered User
 
Gulf Streamers Club
Join Date: Jun 2010
Location: Trois-Rivieres, QC, Canada
Posts: 414
Send a message via Skype™ to normandlegra
Quote:
Originally Posted by rideandslide View Post
I know tere are several different models, as far as options you get on the fan. Our new camper has one ( i'm sure the basic model ) and i had never herd of them. True to their name, it is Fantastic !!!!

There are 5 models of Fantastic fans, $125 to $350. !
Fan-Tastic Vent's Retail 12 Volt Fans
__________________
normandlegra is offline   Reply With Quote
Old 07-19-2015, 07:28 AM   #9
GG1
Senior Member
 
GG1's Avatar
 
Winnebago Owners Club
Join Date: Aug 2002
Location: WHITING,NJ,USA
Posts: 1,082
I dealt with them 2 years ago they diagnosed my problem on the phone, had terrific customer customer service, no charge for the parts I needed I got them in a few days.
__________________

__________________
07 Itasca Ellipse 40fd, 2014 Honda CRV, greyhound lab mix, pit pointer mix(RIP bessie) , shar pei mix, stupid cat, wife
GG1 is offline   Reply With Quote
Reply

Tags
fan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1995 F53 Fan Clutch - defective Ford parts? Adventurer1 Ford Motorhome Chassis Forum 5 11-20-2014 08:19 AM
Fantastic Fan 6500 lift arm broke - help Qwert66 RV Systems & Appliances 3 11-19-2014 10:03 AM
Fantastic fan blowing into coach? Zak Newmar Owner's Forum 9 05-28-2014 09:43 PM
Fantastic Fan Wiring? beartoo RV Systems & Appliances 2 05-12-2014 05:36 AM
Fantastic Fan Upgrade? bdickson RV Systems & Appliances 11 03-07-2014 06:39 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:07 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.