Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > Travel Trailer Discussion
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 04-22-2014, 08:45 AM   #15
Join Date: Apr 2014
Posts: 55
Thanks Imcleister... Had taken taken the old stereo out as it wasn't working when I bought it, maybe because of the battery hookup. I bought a new one and haven't installed it yet so guess I may have been lucky there. Heading out now to level trailer and first try the fridge on propane which I believe will use the 12v circuit to ignite. I realize it will take several on off cycles to purge air from the propane lines. I'll also try the heater...Won't be able to try the water heater until I flush the system and get some water in it.....Again, thanks for your response.

kamu is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-22-2014, 07:15 PM   #16
Join Date: Apr 2014
Posts: 55
Well, went and bought another battery cable today and properly wired my batteries in parallel and here are the results:
1. Replaced bulbs that burned out.
RESULT: All working fine. None of the lenses showed any signs of overheating. Guess that fortunately they burned out before any damage occurred.
2.Changed bathroom fan fuse.
RESULT: Operates normally.
3. Leveled trailer, turned on propane tanks and fired up refrigerator in propane mode.
RESULT: Heard it ignite and then went outside and could hear burner running. So it appears to be ok.
4. Turned thermostat up on heater.
RESULT: Heater ignited and fan came on blowing heat through the vents.
5. Tried my tank meters.
RESULT: Seem to be working normally.
Couldn't fire up the water because I'm still winterized and need to get to a water supply but hoping and assuming that's ok as well.

So, all in all I hope and think I dodged a bullet here. Could have been a lot worse. Just supports the reasoning behind completely checking out your systems before hitting the road whether your trailer is new or older. Had I just taken off with my new (slightly old) trailer would have been a disaster.

Thank you all for your calm support and advice. It's truly appreciated and I hope I can help someone here in the future. I'm sure I'll be back for more advice in the future. Nice to know you folks are here. Again, sincere thanks.

kamu is offline   Reply With Quote
Old 04-22-2014, 09:17 PM   #17
Senior Member
palehorse89's Avatar

Newmar Owners Club
Join Date: Oct 2009
Posts: 6,690
I am glad that you are up and going and figured it out and with no problems to boot! Thank you for the update! Safe travels to ya.......

2000 Newmar MADP 4060, 350ISC, Spartan MM, IFS 2011 Jeep JK, M&G Braking, 2014 MTI 27' Hog Hauler, Wireless brake control, 2006Ultra & 1989 Springer
palehorse89 is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
SMI Air Force One versus US Gear Unified Brake System rvMadness Toads and Motorhome Related Towing 23 06-15-2015 09:58 PM
Rear View System Replacement FleetMan Winnebago Industries Owner's Forum 2 03-15-2014 02:43 AM
Sound system Hwyhermit Technology: Internet, TV, Satellite, Cell Phones, etc. 8 03-14-2014 01:08 PM
Electrical system not working on 4/5 of the motor home USCG CPO Class C Motorhome Discussions 10 06-11-2013 08:59 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:49 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.