Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > Travel Trailer Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-26-2015, 11:08 PM   #1
Junior Member
 
Join Date: Jul 2015
Posts: 6
Blog Entries: 1
Question New TT Owner and a Problem Already

Hello Everyone!! We just bought a 2015 Passport Grand Touring 2920BH Travel Trailer. So we had a great time with our first RV trip and it was a simple over night. We had no problems. It was a dream. We got home and hooked up the TT to power and it all was working. Then today I went in to get it ready for our next over night trip and saw no nights on the Domestic Fridge Panel. So I checked the fuses and the circuit breaker. All of them looked good. So I went to google and looked around and tested the power and even hooked up the fridge to normal house power and still no luck. Any ideas anyone? We are prepping for a few week road trip. Any help on getting this fixed would be great. I also checked the fuses and they look good and tested good.
Thank you Everyone..
__________________

__________________
cimolifam is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-27-2015, 05:11 AM   #2
Senior Member
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Apr 2015
Location: Western WI
Posts: 688
If its under warranty, take it to the dealer. Let them fix or replace it.
__________________

__________________
2001 Itasca Horizon 36LD Cat
Retired Air Force, One lovely Angel, 2 Cats and three birds.
the_vfox is offline   Reply With Quote
Old 07-27-2015, 06:25 AM   #3
Senior Member
 
Join Date: Jul 2013
Location: North Ridgeville, OH
Posts: 532
When you open the fridge door, is the interior light on? If it is, you are getting power to the fridge. If it isn't, check inside the access panel to make sure that the fridge is plugged into the 120 volt outlet. Could the plug have bounced out because it wasn't pushed in far enough?

If you aren't getting any lights on the control panel, and it's plugged in and getting power, I'd say it's time to take it in to the dealer for warranty repair or replacement.
__________________
Retired but busier than ever!
2013 Winnebago 2201DS - 6,200 lbs. or so loaded!
2007 Tundra 5.7
scbwr is offline   Reply With Quote
Old 07-27-2015, 06:29 AM   #4
Senior Member
 
Join Date: Jul 2013
Location: North Ridgeville, OH
Posts: 532
Is your battery connected and charged? If the battery is dead, the fridge won't work properly.
__________________
Retired but busier than ever!
2013 Winnebago 2201DS - 6,200 lbs. or so loaded!
2007 Tundra 5.7
scbwr is offline   Reply With Quote
Old 07-27-2015, 09:35 PM   #5
Junior Member
 
Join Date: Jul 2015
Posts: 6
Blog Entries: 1
There is no light in the fridge or on the panel. The battery is new and has a full charge. I have checked the power plug and it is in all the way. I also plugged it into the normal house power to test and still no luck.
__________________
cimolifam is offline   Reply With Quote
Old 07-28-2015, 06:44 AM   #6
Senior Member
 
Join Date: Jul 2013
Location: North Ridgeville, OH
Posts: 532
Sounds like you need to take it in and get it taken care of under warranty. The control panel could have gone bad. When you call, let them know you have another trip planned....you'll find out how well they take care of their customers with warranty issues.
__________________
Retired but busier than ever!
2013 Winnebago 2201DS - 6,200 lbs. or so loaded!
2007 Tundra 5.7
scbwr is offline   Reply With Quote
Old 07-28-2015, 08:23 AM   #7
Senior Member
 
TDI-Minnie's Avatar
 
Join Date: Sep 2013
Posts: 1,733
When you first came home, the fridge was still on?
You say you plugged it in... where/how/to what?
Do you have 30amp service at the house or was it a household 15/20amp plug? Also, was the air condition on?
__________________

__________________
2013 Winnebago 2301BH-Red
2012 Ram 2500 Megacab HO CTD
TDI-Minnie is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Leveling Jacks Problem locamp Winnebago Industries Owner's Forum 3 12-27-2014 05:48 PM
New RV Owner with problem gchoyke New Member Check-In 10 05-12-2014 08:30 AM
New owner - first problem mricet1005 Tiffin Motorhomes Owners Forum 10 05-10-2014 05:24 PM
Possible new TS owner Sirmowsalot Travel Supreme Owner's Forum 22 04-14-2014 04:12 PM
An Old Problem (the dreaded CC) for a New Owner daveandcarol Ford Motorhome Chassis Forum 3 07-06-2013 07:27 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:13 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.