Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > Travel Trailer Discussion
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 07-14-2013, 08:30 AM   #1
Junior Member
Join Date: Jul 2013
Posts: 2
Norcold n611rt problems

I'm having a problem with my refrigerator unit not running on gas. I've watched the unit fire up an I have a good flame, but the igniter still fires and after about 30 seconds it shuts off and locks itself out. I've replace the flame sensor and am really hoping that it is not the control board. Any suggestions on what else to try?

Flyboyerv is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-14-2013, 09:40 AM   #2
Senior Member
Join Date: Sep 2012
Posts: 4,232
If you have replaced the thermocouple, and it is still doing that, really about the only other thing would be the cntrl board because for some reason it is not reading the thermocouple correctly.

jesilvas is offline   Reply With Quote
Old 07-14-2013, 10:40 AM   #3
Commercial Member
Join Date: Jan 2011
Posts: 52
The model N611 does not have a thermocouple. It senses by resistance through the flame, if electrode tip is out of adjustment distance of 3/16 from burner tube could cause or bad ignition electrode or a bad PC Board.
dforce1 is offline   Reply With Quote
Old 07-14-2013, 02:54 PM   #4
Junior Member
Join Date: Jul 2013
Posts: 2
I'll have to check the distance.

Flyboyerv is offline   Reply With Quote
Old 07-14-2013, 03:35 PM   #5
Join Date: May 2008
Location: ontario
Posts: 95
I had the same with my fridge, tried all the little things first. Had to replace control board $$$, works great now.
Good Luck
rebelcarm is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:17 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.