Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > Travel Trailer Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-16-2016, 01:20 PM   #1
Senior Member
 
Join Date: Jan 2016
Posts: 130
should i be concerned

I have my TT plugged in at the house. The electrical cord has a blue light on it where it plugs into house and a blue light where it plugs into trailer. I noticed last night the blue light is no longer on at the house plug however the blue light is on at the trailer and I have power for AC and microwave. Is this something to worry about and if so any advice on fixing it. thanks
__________________

__________________
cmcguire48 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-16-2016, 01:27 PM   #2
Senior Member
 
plasma800's Avatar
 
Fleetwood Owners Club
Join Date: Nov 2013
Location: Houston, Texas
Posts: 3,003
Blog Entries: 1
if everything is working, probably just the light is bad. You might replace the cord.

Is it a Furrion?
__________________

__________________
RVM#78 - -USAF- F-15 Eagle Radar Vet
2005 Fleetwood Revolution
'12 Chevy 2500HD
'15 Airstream International Signature 27FB
plasma800 is offline   Reply With Quote
Old 07-16-2016, 01:29 PM   #3
Senior Member
 
sdennislee's Avatar


 
Monaco Owners Club
Winnebago Owners Club
Join Date: Sep 2011
Posts: 6,404
Agree the light is probably burned out but if you are worried check the female in of the cord with a meter to verify voltage is correct.
__________________
US Navy Vet, Liberty Tree Member of Oath Keepers, NRA & VFW Life Member, Alaska EMT.
2009 Safari Cheetah 40 SKQ
2009 Winnebago Chalet 231CR
sdennislee is offline   Reply With Quote
Old 07-16-2016, 06:26 PM   #4
Senior Member
 
rideandslide's Avatar


 
Join Date: Sep 2013
Location: Waynesville Georgia
Posts: 1,102
If you are running you air and electonics off of it check you voltage at the trailer while running, to low, damage time !
I bought a great gadget, mine is called a Watt Miser. tell you volts, amperage and KWH that any device pluged into is supplied and using !!
__________________
Lovin Our Grey Wolf 26RL !! Jim & Pat
rideandslide is offline   Reply With Quote
Old 07-19-2016, 09:38 AM   #5
Senior Member
 
Join Date: Jun 2013
Location: Detroit, MI
Posts: 181
The little blue light on mine failed within a week, I just ignored it and all seems fine (2 years later)
__________________
Smithers is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Should we be concerned about water tank freezing (Tiffin Allegro Bay 06 37DB) stravis Class A Motorhome Discussions 6 01-27-2014 07:17 AM
Should I be concerned about storing MH outside in the Pacific Northwest KnightsWatch Newmar Owner's Forum 6 03-22-2013 08:03 PM
1997 Dolphin - should I be concerned? jdefant National RV Owner's Forum 3 06-07-2011 06:21 AM
Should I be concerned (cleaning products) Webetravelin iRV2.com General Discussion 3 04-21-2011 06:50 AM
Should I be concerned about my brakes? tallguy Workhorse and Chevrolet Chassis Motorhome Forum 9 03-27-2006 06:10 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:09 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.