Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > Travel Trailer Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-23-2011, 08:32 AM   #1
Senior Member
 
made2care's Avatar
 
Join Date: Sep 2010
Posts: 136
water heater mystery :(

Took out the water heater yesterday. plumbing was connected and all wiring to control board appears good, however, the 110 was not hooked up and the ouside rocker switch has been removed. I have located the white wire from the heater but not the black. also, it appears as though the previous owner had a major leak. some of the flooring under the sink replaced with new plywood.
Did i purchase a lemon???
__________________

__________________
made2care is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-23-2011, 08:35 AM   #2
Senior Member
 
450Donn's Avatar
 
Join Date: Jun 2006
Location: Dallas,OR
Posts: 2,554
No, Leaks are quite common if owners do not do the preventative maintenance necessary to main them properly. And at that there can still be leaks.
As for the WH is there actually a 120VAC heater element installed? And does it work? I would suspect that somewhere along the line the element was removed or the WH was replaced and to save a few bucks the PO got one without the electric heating element installed.
__________________

__________________
Don and Lorri
2007 Dodge 3500 dually
Resident Dummy.
450Donn is online now   Reply With Quote
Old 05-23-2011, 10:07 AM   #3
Senior Member
 
made2care's Avatar
 
Join Date: Sep 2010
Posts: 136
that makes sense. i will check the element. this model is both electric and gas, but you are correct, they might have burned out the element and just gone with lp.
__________________
made2care is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water heater electric? ebprod Newmar Owner's Forum 22 04-25-2011 11:06 PM
Atwood Water Heater - No electric heat LK23 Winnebago Industries Owner's Forum 5 03-16-2011 05:49 PM
Small leak in the water pump / water heater compartment David K Winnebago Industries Owner's Forum 10 03-01-2011 07:26 PM
Atwood Water Heater Circuit Board Question? leedowney RV Systems & Appliances 5 08-03-2010 12:52 PM
Water Heater and Winterizing bsellers Winnebago Industries Owner's Forum 5 01-07-2008 12:43 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.