RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > Gear and Product Discussions
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-13-2019, 08:17 AM   #1
Senior Member
 
Carefree's Avatar


 
Newmar Owners Club
Join Date: Apr 2016
Location: Carefree, AZ
Posts: 538
SMI Air Force One stopped working

We've had our Air Force One installed for three years and it's been working flawlessly until now. The brake at the toad is no longer being applied when I step on the coach brake - confirmed by my wife sitting in the Jeep when we tested the brake. I swapped the hose between the coach and the Jeep, same result. I don't hear any leak coming from the system.

Any suggestion what I should check next

2016 Newmar Dutchstar and 2016 Jeep Grand Cherokee.
__________________

__________________
Juergen & Margit
2016 Newmar DS 4018
2016 Jeep GC Limited
Carefree is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-13-2019, 08:26 AM   #2
Senior Member


 
Holiday Rambler Owners Club
Join Date: Aug 2015
Posts: 4,071
Juergen-

A question: If you arm the system and pull the breakaway pin, does it move the cylinder attached to the brake pedal?

If not: Is the cable from the cylinder still attached to the firewall?
__________________

__________________
Mark
2008 Holiday Rambler Admiral 30PDD (Ford F-53 chassis)
2009 Honda Fit Sport
l1v3fr33ord1 is offline   Reply With Quote
Old 05-13-2019, 08:30 AM   #3
Senior Member
 
Sky_Boss's Avatar


 
Newmar Owners Club
Freightliner Owners Club
Spartan Chassis
Join Date: Apr 2012
Location: ON THE ROAD...SOMEWHERE
Posts: 6,566
Quote:
Originally Posted by l1v3fr33ord1 View Post
Juergen-

A question: If you arm the system and pull the breakaway pin, does it move the cylinder attached to the brake pedal?

If not: Is the cable from the cylinder still attached to the firewall?
I had something similar a few years ago where the cable in the cylinder broke. I had an older actuator that the opening where th cable entered the actuator had a sharp edge. It has since been replaced with one that has a rounded edge. Still, it is important to make sure you have the straightest line between the firewall anchor and actuator to avoid the cable rubbing on the actuator.

BTW...I also had the first one wiggle out of the firewall anchor too.
__________________
Don, Sandee & GSD Zeus. Guardian GSDs Gunny (7/11/15) & Thor (5/5/15)
2006 2015 DSDP 4320 4369, FL Chassis, 2013 CR-V, Blue Ox Avail, SMI AF1.
Sky_Boss is offline   Reply With Quote
Old 05-13-2019, 08:40 AM   #4
Senior Member
 
mfire1339's Avatar


 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Jun 2008
Location: Glendora Ca.
Posts: 1,434
After the second cable broke I bought better cable from McMaster-Carr.




Mike
__________________
2004 Monaco Monarch
Blueox, SMI, 1990 Wrangler YJ
mfire1339 is offline   Reply With Quote
Old 05-13-2019, 08:59 AM   #5
Senior Member
 
Carefree's Avatar


 
Newmar Owners Club
Join Date: Apr 2016
Location: Carefree, AZ
Posts: 538
Quote:
Originally Posted by l1v3fr33ord1 View Post
Juergen-

A question: If you arm the system and pull the breakaway pin, does it move the cylinder attached to the brake pedal?

If not: Is the cable from the cylinder still attached to the firewall?
Great suggestion. When I pull the pin the brake slams shut, which means the system on the Jeep side is being charged. Right? The connection to the brake cylinder is not broken and seems solid. Maybe my brake cylinder went bad?
__________________
Juergen & Margit
2016 Newmar DS 4018
2016 Jeep GC Limited
Carefree is offline   Reply With Quote
Old 05-13-2019, 09:09 AM   #6
Senior Member
 
mfire1339's Avatar


 
Monaco Owners Club
Workhorse Chassis Owner
Join Date: Jun 2008
Location: Glendora Ca.
Posts: 1,434
Remember It does not work at a stand still.



Mike
__________________
2004 Monaco Monarch
Blueox, SMI, 1990 Wrangler YJ
mfire1339 is offline   Reply With Quote
Old 05-13-2019, 11:11 AM   #7
Senior Member
 
Carefree's Avatar


 
Newmar Owners Club
Join Date: Apr 2016
Location: Carefree, AZ
Posts: 538
Quote:
Originally Posted by mfire1339 View Post
Remember It does not work at a stand still.



Mike
Wow, I never knew this. I would have sworn that it worked before at stand still. Guess, I need to have my wife in the toad diving a short distance. Thank you.
__________________
Juergen & Margit
2016 Newmar DS 4018
2016 Jeep GC Limited
Carefree is offline   Reply With Quote
Old 05-13-2019, 12:48 PM   #8
Community Moderator
 
Spk64's Avatar


 
Newmar Owners Club
Join Date: Apr 2014
Location: Floyds Knobs, In.
Posts: 6,066
SMI Air Force One stopped working

Mine worked just fine at a stand still.
Just need coach aired up.
I have also tested mine by using air blow gun and applying air to fitting on toad.
__________________
Steve
2002 Newmar Mountain Aire 4095
Spk64 is offline   Reply With Quote
Old 05-13-2019, 04:31 PM   #9
Senior Member
 
Carefree's Avatar


 
Newmar Owners Club
Join Date: Apr 2016
Location: Carefree, AZ
Posts: 538
Did some more probing The coach side seems to be fine. I can feel air coming out of the fitting at the back of the coach when the brakes in the coach are being applied.

I tried to use a compressor nozzle on the Jeep side but it doesn't seem to have any impact at all.

I'm trying to find an installer now near Las Cruces, NM. The local guy here can't get me in at all this month. I might just have to wait until we're in Albuquerque to get it fixed.

Anyway, thanks to everyone for your suggestions. It helped to further diagnose the problem.
__________________
Juergen & Margit
2016 Newmar DS 4018
2016 Jeep GC Limited
Carefree is offline   Reply With Quote
Old 05-14-2019, 07:14 PM   #10
Senior Member
 
Join Date: Sep 2009
Location: Central Indiana
Posts: 487
I think Demco now is the manufacturer/supplier of Air Force One. I just bought some parts from them. They were knowledgeable and responsive. Suggest you call them. 712-725-2311 or 800-543-3626. Maybe they can walk you some quick tests to isolate the problem component
mrboyer is offline   Reply With Quote
Old 05-16-2019, 06:21 AM   #11
Senior Member
 
Freightliner Owners Club
Join Date: Apr 2004
Location: Foothills, Yuma, Az
Posts: 943
Quote:
Originally Posted by mrboyer View Post
I think Demco now is the manufacturer/supplier of Air Force One. I just bought some parts from them. They were knowledgeable and responsive. Suggest you call them. 712-725-2311 or 800-543-3626. Maybe they can walk you some quick tests to isolate the problem component
Yea best answer - Call Tech Support
__________________

__________________
Dale&Susan, 08 Alfa Gold, DaGirlsRv Blog
2015 F-150XLT_1600W Solar_880 AmpHr
Magnum_MS2812
gatorcq is offline   Reply With Quote
Reply

Tags
air



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I know my SMI Air Force One is working? NealC Toads and Motorhome Related Towing 8 06-25-2017 10:45 PM
SMI Air Force One BobGuy Monaco Owner's Forum 8 12-09-2008 02:59 PM
SMI Air Force One question smlranger Toads and Motorhome Related Towing 2 04-05-2008 02:01 PM
Just Installed SMI AIR FORCE ONE Brakes Dutch Star Don Monaco Owner's Forum 11 10-18-2007 03:30 PM
SMI Air Force One Toad Brake System RVDude Toads and Motorhome Related Towing 30 12-18-2006 06:06 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.