Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > Technology: Internet, TV, Satellite, Cell Phones, etc.
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-07-2014, 10:53 PM   #1
Senior Member
 
Join Date: Sep 2010
Posts: 1,864
Pioneer Side camera display not working with turn signals

On our 04 Essex with a Pioneer AVIC-80 DVD back up and side camera display isn't working when turn signal is on. Back system works and even the side camera display works if you use the camera switch on the dash but when you use the turn signals the display comes on for 1 sec. and then picture start rolling and you have no picture. Went under dash and checked all connecting on video boxes and all were clean and tight and no change. Any suggest on who one would contact on this problem.
__________________

__________________
tom chelbana is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-08-2014, 05:27 AM   #2
Senior Member
 
94-Newmar's Avatar
 
Join Date: Nov 2009
Posts: 2,043
You'll have to obtain the info from Newmar to be exact on this but my assumption is that they are using a multi source switching device to supply the 3 different video signals to the Pioneer unit since it only has provisions for 1 external video source available to it.

The switching device has 12volt inputs for reverse, left and right turn signals wired to it and all 3 video sources connected to it. When it senses 12v on the left turn it automatically feeds the left camera thru to the Pioneer unit, same for right turn and reverse. This is how they can get 3 different camera inputs into only 1 input at the monitor/screen.

It is not unusual for those video switchers to fail - I seem to replace a few yearly regardless of the manufacturer.

To verify it has failed, once you've located the switcher, you can easily swap the left or right camera cable with the rear cable and then test. If the rear camera is now experiencing the odd behavior you describe as rolling once and going away, then you've confirmed the switcher is at fault.
__________________
94-Newmar Kountry Star 40-KSDP
Spartan/Cummins 8.3C-300HP/Allison 3060 WTEC-II/25yr RV Tech RVIA Certified/Onan-Cummins Certified
94-Newmar is offline   Reply With Quote
Reply

Tags
camera



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake Lights and Turn Signals Not Working slimjim69 Ford Motorhome Chassis Forum 7 09-09-2014 10:35 PM
Loss of turn signals and flashers jluke Ford Motorhome Chassis Forum 15 06-29-2014 02:51 PM
Turn Signals Light Up When Brake Pedal Is Pushed MarkinOR Monaco Owner's Forum 5 05-06-2014 05:05 PM
Turn Signals / Emergency Flasher Relay robbyk Fleetwood Products Owner's Forum 17 04-29-2014 06:08 PM
LED side turn signals deSanford Monaco Owner's Forum 15 12-19-2013 12:35 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:41 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.