Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > Technology: Internet, TV, Satellite, Cell Phones, etc.
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-21-2018, 09:37 AM   #1
Junior Member
 
Join Date: May 2018
Posts: 5
Weldex Monitor intermittantly working

Okay, this Weldex backup monitor is about to drive me nuts. It is the original in our 2005 American Coach Tradition. I think the 3000 model. Anyways, it will intermittantly work. WHen it does, it gives me good picture. When it doesn't, it will just be a white screen. Drove 600 miles the other day and it was white the whole time. Noticed at the end of the drive when I hit the View button on my Trip Tek computer then it would work then go out after a few minutes. Think it may be related to that. Not sure. Drove 250 miles yesterday and the darn thing worked flawlessly the entire drive. I have not idea what is wrong with it. Anyone else experiencing the same problems?
__________________

dbhhcolor is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-21-2018, 10:15 AM   #2
Andy & Elaine
 
2008Seneca's Avatar


 
Jayco Owners Club
Join Date: Feb 2018
Location: Arizona
Posts: 600
We have replaced them for a few reasons including 'noise' on the screen, lack of color, and just plain outdated. We have always chosen the replacement systems from Rear View Safety.
__________________

__________________
Always at home wherever we roam.
2008 Jayco Seneca 35GS
2008Seneca is offline   Reply With Quote
Old 06-21-2018, 10:24 AM   #3
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 31,060
Hi ! Welcome to IRV2! We're sure glad you joined the gang!

Sorry I don't know about that system.


Good luck, happy trails, and God bless!
__________________
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 06-21-2018, 10:25 AM   #4
Senior Member
 
CountryB's Avatar


 
Join Date: Aug 2017
Location: Orlando, Florida
Posts: 1,780
I suppose it could be the camera, wiring, or display/monitor unit.

Do you have another display you could plug it into when its acting up to see if the picture is clear when switching displays?

An old computer monitor (with RCA jack input) or TV will work. Maybe a DVD player with "RCA input" that you could then feed signal to your coach's TV for testing.
__________________
- Mike
2005 Beaver Patriot-Thunder, 42ft, 525HP Cat C13, Allison 4000, 2014 V-Star 1300 Deluxe Bagger
CountryB is offline   Reply With Quote
Old 06-23-2018, 08:25 PM   #5
Junior Member
 
Ford Super Duty Owner
Join Date: Mar 2011
Posts: 16
I have the Weldex in my Bounder too. It was going flaky like yours. Someone (probably here) pointed out a common problem with the connector in the rear. I unscrewed the camera from the rear and fished out cable until I got to the connector. I snipped off the connector and replaced it with a better one. (only 4 wires as I recall)

With new connector it has been rock solid ever since. (5 years or so)
bolhuijo is offline   Reply With Quote
Old 06-24-2018, 05:55 AM   #6
Senior Member
 
rbpower's Avatar
 
Join Date: Nov 2013
Posts: 322
mine has not worked form the day i got the coach. i will be watching this for a posible fix
rbpower is offline   Reply With Quote
Old 06-24-2018, 07:33 AM   #7
Junior Member
 
Join Date: May 2018
Posts: 5
I will attempt bolhuijo's solution. If that does not work, then I am just going to replace the unit. More to follow?

2008Seneca - does Rear View Safety have the same system or is it another system? Did you have to fish the cable the entire length of the coach or did you just replace the camera and monitor?

Thanks all.
__________________

dbhhcolor is offline   Reply With Quote
Reply

Tags
monitor



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stair continues to open intermittantly galluta RV Systems & Appliances 6 10-01-2013 01:12 PM
Jacks beeping intermittantly. Vivnme Monaco Owner's Forum 13 09-10-2012 07:25 PM
Weldex Monitor Mount BB501 MH-General Discussions & Problems 3 01-20-2008 07:25 AM
Headlights Intermittantly Flashing Kerry1 Freightliner Motorhome Chassis Forum 5 11-04-2007 10:13 AM
Weldex backup monitor Barry60 MH-General Discussions & Problems 4 05-05-2007 10:20 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:37 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.