RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-18-2019, 08:12 AM   #1
Junior Member
 
Join Date: Apr 2019
Posts: 1
Aqua Hot Problems

our aqua hot system seems to be emitting a lot of white smoke, and the diesel smell is strong. We just had it serviced at an RV dealer ship ($500) on the first trip. recently on the second trip it will not even fire off.....ideas?
__________________

RBGH is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-18-2019, 10:49 AM   #2
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 39,481
Hi ! Welcome to IRV2! We're sure glad you joined the gang!

No knowledge of Aquahot but wanted to say hello!

Good luck, happy trails, and God bless!
__________________

__________________
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is online now   Reply With Quote
Old 10-18-2019, 07:21 PM   #3
Senior Member
 
Piros1's Avatar
 
Join Date: Dec 2015
Location: Dittmer, MO 63023
Posts: 332
Quote:
Originally Posted by RBGH View Post
our aqua hot system seems to be emitting a lot of white smoke, and the diesel smell is strong. We just had it serviced at an RV dealer ship ($500) on the first trip. recently on the second trip it will not even fire off.....ideas?


There is a lot of possibilities, if you are up to the task go online to Aqua Hots website and check out their diagnostic charts. Follow it to the letter and don’t take short cuts and it will direct yo the problem. It could be an adjustment or a bad control board but I wouldn’t replace parts until you diagnose it.
__________________
2005 CC Affinity 770, 2006 Jeep TJ
Piros1 is online now   Reply With Quote
Reply

Tags
aqua hot, ems, problem, problems



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Aqua Hot solution to my hot, cold, hot water problem JeffK Entegra Owner's Forum 38 06-25-2017 04:54 PM
Aqua Hot--not hot srx-6 MH-General Discussions & Problems 21 03-04-2010 05:58 PM
Hydro Hot Service (Aqua Hot) Wayne R RV Systems & Appliances 15 03-13-2009 07:25 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:17 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×