Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 11-05-2010, 10:47 AM   #1
Join Date: Apr 2007
Location: Maryville,TN
Posts: 58
Question Atwood 6 Gal Hot water problem

Water heater will heat on both propane and AC power, but no flow inside the MH on hot water faucets. When I open the faucet and you get a small surge then the flow stops. I drained the tank and the water is hot. Anyone have any ideas?

TNBULLDOG is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-05-2010, 01:03 PM   #2
Join Date: Nov 2007
Location: Montreal/Florida
Posts: 31
You likely have a stuck/defective check valve on the output of the tank (pipe coming out on the top of the tank) Try tapping it or simply remove and replace (with a metal one if plastic).
Alfa 38 5ver (Florida)
Montreal/Florida Snowbird
Alfa38User is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Atwood Water Heater problem pcoopy RV Systems & Appliances 7 12-29-2010 03:44 PM
Fleetwood Hot Water Problem MarkLI MH-General Discussions & Problems 5 06-07-2009 07:38 AM
Atwood Hot water heater not heating (quick, leaving tomorrow!) MandT RV Systems & Appliances 12 07-25-2008 11:48 AM
Atwood hot water heater electric switch melted. POLL N8XV iRV2.com General Discussion 1 04-10-2008 03:16 AM
Atwood Hot Water Heater Not Hot GG1 Winnebago Industries Owner's Forum 3 07-11-2005 04:25 PM

» Virginia Campgrounds

Reviews provided by

Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:10 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.